Bug 999315 - RFE: [PATCH] fix for the intel driver to be able report its name correctly over DRI
RFE: [PATCH] fix for the intel driver to be able report its name correctly ov...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 03:03 EDT by carasin
Modified: 2014-07-05 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.99
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-05 08:29:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdpauinfo log with va_gl back-end on Intel GMA HD3000 (16.18 KB, text/plain)
2013-08-28 02:48 EDT, carasin
no flags Details

  None (edit)
Description carasin 2013-08-21 03:03:28 EDT
Description of problem:

There is a VDPAU va_gl back-end that allows using VAAPI for the hardware accelerated video playback over the VDPAU. Now libvdpau tries to choose libvdpau_nvidia.so instead libvdpau_i965.so when using Intel HD Graphics. It happens because intel driver does not report its name correctly over DRI. There is a patch to fix this issue:
http://lists.freedesktop.org/archives/intel-gfx/2013-August/032031.html
_______________________

Version-Release number of selected component (if applicable):

2.21-14, 2.21-12 and earlier

_______________________

How reproducible:

Always
_______________________

Steps to Reproduce:

1. Use Intel HD Graphics with xorg-x11-drv-intel driver
2. $ vdpauinfo
_______________________

Actual results:

It tries to choose libvdpau_nvidia.so instead libvdpau_i965.so
_______________________

Expected results:

It tries to choose libvdpau_i965.so
_______________________

Additional info:

https://bugzilla.rpmfusion.org/show_bug.cgi?id=2897
Comment 1 carasin 2013-08-28 02:42:57 EDT
I've applied the patch and built the package. I've updated xorg-x11-drv-intel on my laptop with F19 installed. Now vdpauinfo says:
>>> $ vdpauinfo 
>>> display: :0   screen: 0
>>> Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
>>> Error creating VDPAU device: 1
And if I install libvdpau-va-gl then vdpauinfo says that HW-accelerated video playback exists! Now there is no need for VDPAU_DRIVER=i965 option!
Comment 2 carasin 2013-08-28 02:48:05 EDT
Created attachment 791265 [details]
vdpauinfo log with va_gl back-end on Intel GMA HD3000

Note You need to log in before you can comment on or make changes to this bug.