Bug 999339 - Deleting a workspace does not remove all the workspace nodes
Deleting a workspace does not remove all the workspace nodes
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
x86_64 All
unspecified Severity unspecified
: ER2
: 6.0
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 04:01 EDT by Horia Chiorean
Modified: 2016-02-10 03:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:53:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2009 Blocker Closed Delete workspace should also delete child nodes permanently 2014-02-12 05:42:41 EST

  None (edit)
Description Horia Chiorean 2013-08-21 04:01:08 EDT
When removing a JCR workspace via workspace.remove(wsName) not only the workspace itself should be deleted, but also all the nodes below that workspace.

Currently if a workspace is deleted and then re-created with the same name, all its former nodes are still accessible. This should not happen.
Comment 1 JBoss JIRA Server 2013-08-22 10:27:01 EDT
K. Bachl <korbinian.bachl@googlemail.com> made a comment on jira MODE-2009

Hello Horia, Hello Randall,

can you please also check the Workspace.clone() operations? It turns out that this also seems affected, as if I import a new workspace and then clone this into another workspace, the old content there isn't emptied correctly right before, leading to all kinds of stale data and JCR integrity exceptions (funny when you want to overwrite it...) or stale data returning as it seems some nodes then appear duplicate etc;
Comment 2 JBoss JIRA Server 2013-08-22 10:28:46 EDT
K. Bachl <korbinian.bachl@googlemail.com> made a comment on jira MODE-2009

wrong field entered content - sorry;
Comment 3 Horia Chiorean 2013-08-23 03:22:24 EDT
Cherry-picked from community branch & fixed conflicts: https://github.com/jboss-integration/modeshape/commit/69b69582c8c13b2e2f9ff81e0b2a39a99cf5b049
Comment 8 belong 2013-11-19 18:15:46 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 9 Filip Nguyen 2014-02-12 05:42:34 EST
Verified. After adding a new workspace with node and recreating the workspace, the nodes of the initial created workspace are no longer present.

Note You need to log in before you can comment on or make changes to this bug.