Bug 999352 - virsh migrate with dname parameter fails
virsh migrate with dname parameter fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 04:31 EDT by Pavel Hrdina
Modified: 2014-06-17 20:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:08:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Hrdina 2013-08-21 04:31:14 EDT
Description of problem:
A migration of the guest fails with an error message using dname parameter to change the name of the guest.

Version-Release number of selected component (if applicable):
upstream c753749c27fb48d481e64953d59668731e5e2dbd

How reproducible:
always

Steps to Reproduce:
1. prepare any guest for migration

2. run the command 'virsh migrate --live --domain migr-test --desturi qemu+ssh://ip.address/system --dname migr-test2'

Actual results:
error: internal error: Incoming cookie data had unexpected name migr-test vs migr-test2

Expected results:
The migration should finish successfully without an error.
Comment 2 Jiri Denemark 2013-09-04 03:49:31 EDT
This is now fixed upstream by v1.1.2-43-g8d67c55:

commit 8d67c550e931f1dbc163e7e20784218edc1165df
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Tue Sep 3 15:17:03 2013 +0200

    qemu: Make domain renaming work during migration
    
    https://bugzilla.redhat.com/show_bug.cgi?id=999352
    
    Since commit v1.0.5-56-g449e6b1 (Pull parsing of migration xml up into
    QEMU driver APIs) any attempt to rename a domain during migration fails
    with the following error message:
    
        internal error Incoming cookie data had unexpected name DOM vs DOM2
    
    This is because migration cookies always use the original domain name
    and the mentioned commit failed to propagate the name back to
    qemuMigrationPrepareAny.
Comment 4 zhe peng 2013-09-08 23:35:02 EDT
Can reproduct this with:
libvirt-1.1.1-2.el7.x86_64

verify with build:
libvirt-1.1.1-4.el7

step:
1:prepare migration env.
2:in source, start a guest
#virsh list --all
Id    Name                           State
----------------------------------------------------
 3     rhel7                          running

3: do migration
# virsh migrate --live --domain rhel7 --desturi qemu+ssh://$DST_ip/system --dname rhel-mig

4: no error occured, check guest on DST
# virsh list --all
 Id    Name                           State
----------------------------------------------------
 2     rhel-mig                       running

move to verified.
Comment 5 Ludek Smid 2014-06-13 08:08:45 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.