Bug 999444 - 'loan settings' not work on edit system page
'loan settings' not work on edit system page
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
Unspecified Unspecified
low Severity medium (vote)
: 19.0
: ---
Assigned To: Dan Callaghan
tools-bugs
: Patch
Depends On: 1014438
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 06:34 EDT by wangjing
Modified: 2014-11-25 02:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-25 02:18:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wangjing 2013-08-21 06:34:10 EDT
Description of problem:
'loan settings' not work on edit system page

Version-Release number of selected component (if applicable):
beaker-devel Version - 0.14.1

How reproducible:
always

Steps to Reproduce:
1. visit system page, and click 'edit system'.
2. then click 'loan settings'.
3. input user in 'Loan To' and click button 'update loan'.

Actual results:
no response.

Expected results:
the feature should work as on *view* system page.

Additional info:
Comment 2 Nick Coghlan 2013-09-30 20:29:53 EDT
This problem still exists in 0.15

An acceptable alternative to making it work would be to simply hide the non-functional controls when in the edit view.
Comment 3 Nick Coghlan 2013-09-30 21:19:19 EDT
Including this with the other loan UI cleanups planned for 0.15.1
Comment 5 Raymond Mancy 2013-10-25 00:40:06 EDT
Normally the problem in this situation, is that the widget is not being returned directly in the controller, or is not a member widget of a widget that is. That explains why it doesn't work in the 'edit' page. It does not explain why it does work in the regular page.

It turns out that by some stroke of magic the LoanWidget's resources are being added to the TaskSearchForm widget instance, which is being returned at the top level of the relevant controller method.

Ignoring that though, the solution here I think is just to return the LoanWidget instance from the controller as well.
Comment 6 Raymond Mancy 2013-10-25 00:55:17 EDT
Actually no, the correct solution is to make LoanWidget a member widget of SystemForm.
Comment 7 Raymond Mancy 2013-10-25 01:12:36 EDT
http://gerrit.beaker-project.org/#/c/2404/
Comment 8 Dan Callaghan 2013-11-11 01:40:45 EST
Do we need to show the loan widget at all on the edit page?
Comment 9 Raymond Mancy 2013-11-11 22:20:11 EST
Not necessarily. My only reservation is having some widgets mysteriously removed and others not, and for no other reason other than that's what we decided to do (and then have people raise bugs because they don't know any better) 

I'd be more happy with removing all widgets that are not directly related to editing a system, or keeping them all.
Comment 10 Dan Callaghan 2014-09-18 01:58:22 EDT
This has been fixed as part of the system page redesign (bug 1014438).

https://beaker-project.org/dev/proposals/system-page-improvements.html
Comment 13 Dan Callaghan 2014-11-25 02:18:09 EST
Beaker 19.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.