This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 999470 - Stop VM after suspend+resume is failing (from the webadmin)
Stop VM after suspend+resume is failing (from the webadmin)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sergey Gotliv
meital avital
virt
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 07:26 EDT by Meital Bourvine
Modified: 2015-09-22 09 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 05:22:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (12.43 MB, application/x-gzip)
2013-08-22 08:30 EDT, Meital Bourvine
no flags Details

  None (edit)
Description Meital Bourvine 2013-08-21 07:26:53 EDT
Description of problem:
Stop VM after suspend and resume fails.

Version-Release number of selected component (if applicable):
vdsm-4.12.0-61.git8178ec2.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Have a running VM
2. Suspend VM
3. Resume VM
4. Stop VM

Actual results:
2013-08-21 10:37:17,586 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-1) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Shutdown of VM test1 failed

Expected results:
It will succeed stopping the VM
Comment 1 Allon Mureinik 2013-08-22 06:51:49 EDT
Please add engine and VDSM logs
Comment 2 Meital Bourvine 2013-08-22 08:30:42 EDT
Created attachment 789172 [details]
logs
Comment 3 Allon Mureinik 2013-08-22 10:15:38 EDT
The relevant error seems to be:
Thread-1276::WARNING::2013-08-21 10:45:07,819::clientIF::361::vds::(teardownVolumePath) Drive is not a vdsm image: VOLWM_CHUNK_MB:1024 VOLWM_CHUNK_REPLICATE_MULT:2 VOLWM_FREE_PCT:50 _blockDev:False _checkIoTuneCategories:<bound method Drive._checkIoTuneCategories of <vm.Drive object at 0x7f5010057890>> _customize:<bound method Drive._customize of <vm.Drive object at 0x7f5010057890>> _deviceXML:<disk device="cdrom" snapshot="no" type="file"><source file="" startupPolicy="optional"/><target bus="ide" dev="hdc"/><readonly/><serial></serial></disk> _makeName:<bound method Drive._makeName of <vm.Drive object at 0x7f5010057890>> _validateIoTuneParams:<bound method Drive._validateIoTuneParams of <vm.Drive object at 0x7f5010057890>> address:{u'bus': u'1', u'controller': u'0', u'type': u'drive', u'target': u'0', u'unit': u'0'} alias:ide0-1-0 apparentsize:0 blockDev:False cache:none conf:{'status': 'Down', 'custom': {}, 'acpiEnable': 'true', 'emulatedMachine': 'rhel6.4.0', 'vmId': '0c26f6aa-4d37-4f8b-9ead-9d191668cacc', 'pid': '32174', 'memGuaranteedSize': 1024, 'timeOffset': '0', 'keyboardLayout': 'en-us', 'displayPort': u'5902', 'displaySecurePort': u'5903', 'spiceSslCipherSuite': 'DEFAULT', 'cpuType': 'Conroe', 'cpuShares': '1024', 'pauseCode': 'NOERR', 'clientIp': '', 'exitCode': 0, 'nicModel': 'rtl8139,pv', 'smartcardEnable': 'false', 'kvmEnable': 'true', 'exitMessage': 'SaveState succeeded', 'transparentHugePages': 'true', 'devices': [{'device': 'scsi', 'alias': u'scsi0', 'model': 'virtio-scsi', 'type': 'controller', 'address': {u'slot': u'0x04', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}}, {'alias': u'video0', 'specParams': {'vram': '65536', 'heads': '1'}, 'deviceId': 'bc89e211-5153-404a-bb82-5adf88853d74', 'address': {u'slot': u'0x02', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, 'device': 'qxl', 'type': 'video'}, {'nicModel': 'pv', 'macAddr': '00:1a:4a:23:a1:1f', 'linkActive': True, 'network': 'rhevm', 'alias': u'net0', 'custom': {}, 'filter': 'vdsm-no-mac-spoofing', 'specParams': {}, 'deviceId': '19da5bec-8a3a-4cb0-8b95-d1464c9c12aa', 'address': {u'slot': u'0x03', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, 'device': 'bridge', 'type': 'interface', 'name': u'vnet1'}, {'index': '2', 'iface': 'ide', 'name': u'hdc', 'alias': u'ide0-1-0', 'address': {u'bus': u'1', u'controller': u'0', u'type': u'drive', u'target': u'0', u'unit': u'0'}, 'specParams': {'path': ''}, 'readonly': 'True', 'deviceId': '52d30510-c2dd-46f3-8d79-bbffabc6a2c1', 'path': '', 'device': 'cdrom', 'shared': 'false', 'type': 'disk'}, {'address': {u'slot': u'0x06', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, 'volumeInfo': {'path': '/rhev/data-center/1fe09247-4b5e-4078-8307-72315184e554/0b95a82f-5a9d-4303-8b74-0258a7de1853/images/1cd1d82c-0015-4ca6-824a-8f5092ab0038/3384f10d-445d-46b8-8643-c134dfe70722', 'volType': 'path'}, 'index': 0, 'iface': 'virtio', 'apparentsize': '5368709120', 'alias': u'virtio-disk0', 'imageID': '1cd1d82c-0015-4ca6-824a-8f5092ab0038', 'readonly': 'False', 'shared': 'false', 'truesize': '5368709120', 'type': 'disk', 'domainID': '0b95a82f-5a9d-4303-8b74-0258a7de1853', 'reqsize': '0', 'format': 'raw', 'deviceId': '1cd1d82c-0015-4ca6-824a-8f5092ab0038', 'poolID': '1fe09247-4b5e-4078-8307-72315184e554', 'device': 'disk', 'path': '/rhev/data-center/1fe09247-4b5e-4078-8307-72315184e554/0b95a82f-5a9d-4303-8b74-0258a7de1853/images/1cd1d82c-0015-4ca6-824a-8f5092ab0038/3384f10d-445d-46b8-8643-c134dfe70722', 'propagateErrors': 'off', 'optional': 'false', 'name': u'vda', 'volumeID': '3384f10d-445d-46b8-8643-c134dfe70722', 'specParams': {}, 'volumeChain': [{'path': '/rhev/data-center/1fe09247-4b5e-4078-8307-72315184e554/0b95a82f-5a9d-4303-8b74-0258a7de1853/images/1cd1d82c-0015-4ca6-824a-8f5092ab0038/3384f10d-445d-46b8-8643-c134dfe70722', 'domainID': '0b95a82f-5a9d-4303-8b74-0258a7de1853', 'vmVolInfo': {'path': '/rhev/data-center/1fe09247-4b5e-4078-8307-72315184e554/0b95a82f-5a9d-4303-8b74-0258a7de1853/images/1cd1d82c-0015-4ca6-824a-8f5092ab0038/3384f10d-445d-46b8-8643-c134dfe70722', 'volType': 'path'}, 'volumeID': '3384f10d-445d-46b8-8643-c134dfe70722', 'imageID': '1cd1d82c-0015-4ca6-824a-8f5092ab0038'}]}, {'target': 1048576, 'alias': u'balloon0', 'specParams': {'model': 'virtio'}, 'deviceId': '41567041-b929-4a54-adbe-84aecc910bb4', 'address': {u'slot': u'0x07', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}, 'device': 'memballoon', 'type': 'balloon'}, {'device': u'usb', 'alias': u'usb0', 'type': 'controller', 'address': {u'slot': u'0x01', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x2'}}, {'device': u'ide', 'alias': u'ide0', 'type': 'controller', 'address': {u'slot': u'0x01', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x1'}}, {'device': u'virtio-serial', 'alias': u'virtio-serial0', 'type': 'controller', 'address': {u'slot': u'0x05', u'bus': u'0x00', u'domain': u'0x0000', u'type': u'pci', u'function': u'0x0'}}, {'device': u'unix', 'alias': u'channel0', 'type': u'channel', 'address': {u'bus': u'0', u'controller': u'0', u'type': u'virtio-serial', u'port': u'1'}}, {'device': u'unix', 'alias': u'channel1', 'type': u'channel', 'address': {u'bus': u'0', u'controller': u'0', u'type': u'virtio-serial', u'port': u'2'}}, {'device': u'spicevmc', 'alias': u'channel2', 'type': u'channel', 'address': {u'bus': u'0', u'controller': u'0', u'type': u'virtio-serial', u'port': u'3'}}], 'smp': '1', 'vmType': 'kvm', 'memSize': 1024, 'displayIp': '0', 'spiceSecureChannels': 'smain,sinputs,scursor,splayback,srecord,sdisplay,susbredir,ssmartcard', 'smpCoresPerSocket': '1', 'vmName': 'test2', 'display': 'qxl', 'nice': '0'} createXmlElem:<bound method Drive.createXmlElem of <vm.Drive object at 0x7f5010057890>> device:cdrom deviceId:52d30510-c2dd-46f3-8d79-bbffabc6a2c1 drv:raw getNextVolumeSize:<bound method Drive.getNextVolumeSize of <vm.Drive object at 0x7f5010057890>> getXML:<bound method Drive.getXML of <vm.Drive object at 0x7f5010057890>> iface:ide index:2 isDiskReplicationInProgress:<bound method Drive.isDiskReplicationInProgress of <vm.Drive object at 0x7f5010057890>> isVdsmImage:<bound method Drive.isVdsmImage of <vm.Drive object at 0x7f5010057890>> log:<logUtils.SimpleLogAdapter instance at 0x7f50340ba4d0> name:hdc networkDev:False path: readonly:True reqsize:0 serial: shared:false specParams:{'path': ''} truesize:0 type:cdrom volExtensionChunk:1024 watermarkLimit:536870912
Traceback (most recent call last):
  File "/usr/share/vdsm/clientIF.py", line 355, in teardownVolumePath
    res = self.irs.teardownImage(drive['domainID'],
  File "/usr/share/vdsm/vm.py", line 1343, in __getitem__
    raise KeyError(key)
KeyError: 'domainID'

Sergey - aren't you already handling a similar bug?
Comment 4 Sergey Gotliv 2013-08-22 14:05:55 EDT
Meital, what do you mean by "failure"? What is the user experience? I mean something stop working, VM becomes useless, what happens?

If Allon is right and this exception is the "failure", so this is log issue only, since this exception is caught and treated and has no any affect on user.
Comment 5 Meital Bourvine 2013-08-25 02:05:44 EDT
VM keeps working, cannot shut it down.
Comment 6 Omer Frenkel 2013-08-27 05:22:15 EDT
graceful shutdown require Guest-agent or working ACPI.
this is not the case for the vm in this bug.

i verified that shutting down gracefully a vm with guest is possible after suspend and resume, as reported in the description.

please re-open if you think there is a bug here.

Note You need to log in before you can comment on or make changes to this bug.