Bug 999499 - release does not reset active cursors on priority queues
release does not reset active cursors on priority queues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity unspecified
: 3.0
: ---
Assigned To: Gordon Sim
Zdenek Kraus
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 08:26 EDT by Gordon Sim
Modified: 2015-01-21 07:56 EST (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:56:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a simple reproducer (2.10 KB, text/x-c++src)
2013-08-21 08:26 EDT, Gordon Sim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5085 None None None Never

  None (edit)
Description Gordon Sim 2013-08-21 08:26:05 EDT
Created attachment 788840 [details]
a simple reproducer

Description of problem:


Version-Release number of selected component (if applicable):

Since qpid-0.20

How reproducible:

100%

Steps to Reproduce:
1. put a message in a priority queue
2. create a receiver from that queue
3. fetch the message then release
4. try to fetch it again


Actual results:

Subsequent fetch() attempts on released message fail.

Expected results:

Subsequent fetch() attempts on released message return the released message.

Additional info:

Using attached reproducer, the bug is that the test stops after fetching the message once. When fixed it continues in a loop refetching the same released message. Upstream fix also includes a simple (similar) test case.
Comment 1 Gordon Sim 2013-08-21 08:27:52 EDT
Fixed upstream: https://svn.apache.org/r1515793. Note this would be a regression from previous MRG releases.
Comment 3 Gordon Sim 2013-08-23 04:40:14 EDT
Backported to 0.22-mrg branch here: http://git.app.eng.bos.redhat.com/?p=rh-qpid.git;a=shortlog;h=refs/heads/0.22-mrg-BZ999499
Comment 4 Zdenek Kraus 2014-05-02 04:26:08 EDT
Tested on RHEL 6 i686 && x86_64 with following packaged:

qpid-cpp-client-0.22-38
qpid-cpp-client-devel-0.22-38
qpid-cpp-client-devel-docs-0.22-38
qpid-cpp-client-rdma-0.22-38
qpid-cpp-debuginfo-0.22-38
qpid-cpp-server-0.22-38
qpid-cpp-server-devel-0.22-38
qpid-cpp-server-ha-0.22-38
qpid-cpp-server-linearstore-0.22-38
qpid-cpp-server-rdma-0.22-38
qpid-cpp-server-xml-0.22-38

works as expected.

Note You need to log in before you can comment on or make changes to this bug.