Bug 999535 - glibc should build an uz_UZ.UTF-8 locale, not only the Latin1 locales uz_UZ uz_UZ.iso88591
glibc should build an uz_UZ.UTF-8 locale, not only the Latin1 locales uz_UZ u...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 09:55 EDT by Mike FABIAN
Modified: 2016-11-24 10:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 12:38:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glibc-fedora-localedata-uz-utf8.patch (351 bytes, patch)
2013-08-21 09:57 EDT, Mike FABIAN
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 16095 None None None Never

  None (edit)
Description Mike FABIAN 2013-08-21 09:55:35 EDT
Version-Release number of selected component (if applicable):
glibc-2.17

Description of problem:

We have no UTF-8 locale for Uzbek written in Latin script:

    mfabian@ari:~
    $ locale -a | grep ^uz
    uz_UZ
    uz_UZ.iso88591
    uz_UZ.utf8@cyrillic
    uz_UZ@cyrillic
    mfabian@ari:~
    $ LC_ALL=uz_UZ locale charmap
    ISO-8859-1
    mfabian@ari:~
    $

I.e., although we have an UTF-8 locale for Uzbek written in Cyrillic
script, the Uzbek locales for Latin script are available only in
ISO-8859-1 encoding.

But Latin script is more common nowadays for Uzbek, see:

    http://en.wikipedia.org/wiki/Uzbek_language#Writing_systems

CLDR also made Latin script the default for Uzbek recently, see

    http://unicode.org/cldr/trac/ticket/6548 (Update country/language/pop for Uzbek)
    
    http://unicode.org/cldr/trac/changeset/9155 (cldrbug 6548: Updated Uzbekistan Latin/Cyrillic? usage to better reflect modern education / usage.)

Therefore, the default locale chosen by Anaconda for Uzbek should
also use Latin script now, but it is not nice to use a non-UTF-8 locale
nowadays.

Therefore, we should also build an uz_UZ.UTF-8 locale.
Comment 1 Mike FABIAN 2013-08-21 09:57:33 EDT
Created attachment 788886 [details]
glibc-fedora-localedata-uz-utf8.patch

Patch for our glibc package in f19 and rawhide to build
an uz_UZ.UTF-8 locale.
Comment 2 Mike FABIAN 2013-08-21 09:59:58 EDT
I did a test build of glibc for f19 with the patch from comment#1 and
it works:

    mfabian@ari:~
    $ locale -a | grep ^uz
    uz_UZ
    uz_UZ.iso88591
    uz_UZ.utf8
    uz_UZ.utf8@cyrillic
    uz_UZ@cyrillic
    mfabian@ari:~
    $ LANG=uz_UZ.UTF-8 locale charmap
    UTF-8
    mfabian@ari:~
    $ LANG=uz_UZ.UTF-8 date
    21 Avgust, 2013 yil, Chorshanba
    mfabian@ari:~
    $
Comment 3 Carlos O'Donell 2013-08-21 10:17:01 EDT
Thanks.
Comment 4 Mike FABIAN 2013-10-28 10:35:15 EDT
The problem still exists in Fedora-20-Beta-TC6-x86_64-netinst.iso
glibc-2.18-11.fc20.x86_64.
Comment 5 Carlos O'Donell 2013-10-28 12:38:55 EDT
Changes to SUPPORTED should happen upstream with consent from the entire community since they represent a firm commitment to provide support for that language in that specific format.

For Fedora to add entries to SUPPORTED would put us under a lot of pressure to support the language in that format without much help from upstream. What we really want to do is remain aligned with upstream. The support should come through upstream into Fedora.

I'm marking this as CLOSED / WONTFIX precisely because the change needs to happen upstream. Please file an upstream bug in sourceware.org tracker for glibc and we can get the ball rolling upstream. Once upstream has a patch you can reopen issues to backport the SUPPORTED changes.
Comment 7 Carlos O'Donell 2013-10-28 13:50:32 EDT
(In reply to Mike FABIAN from comment #6)
> https://sourceware.org/bugzilla/show_bug.cgi?id=16095

Excellent! Thanks Mike. I've taken this upstream and asked Chris Leonard to comment. I hope I wasn't too blunt marking this CLOSED/WONTFIX, but some things need to be handled upstream before Fedora can easily commit to them.
Comment 8 Carlos O'Donell 2013-10-28 15:37:12 EDT
I've adjusted the closed state to CLOSED/UPSTREAM since that's more accurate depiction of the issue.

Note You need to log in before you can comment on or make changes to this bug.