Bug 999543 - Unable to subscribe a system to a valid pool ID using cli
Unable to subscribe a system to a valid pool ID using cli
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Hayk Hovsepyan
: Triaged
Depends On: 997869
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 10:09 EDT by Sachin Ghai
Modified: 2014-04-24 13:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 997869
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Ghai 2013-08-21 10:09:41 EDT
+++ This bug was initially created as a clone of Bug #997869 +++

Description of problem:
Unable to subscribe a system to a valid pool ID using cli commands

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-7.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
katello-cli-1.4.3-7.el6sat.noarch
katello-common-1.4.3-8.el6sam_splice.noarch
katello-headpin-1.4.3-8.el6sam_splice.noarch
katello-headpin-all-1.4.3-8.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch


How reproducible:
everytime

Steps to Reproduce:

# headpin -u admin -p **** org subscriptions --name ACME_Corporation 
------------------------------------------------------------------------------------------------------------------------------------------------------
                                                             Organization's Subscriptions
------------------------------------------------------------------------------------------------------------------------------------------------------

Subscription    : Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90c041408684b6014086873902007d
Limits:
    [ Sockets: 2 ]
Start Date      : 2012/12/31 05:00:00
End Date        : 2013/12/31 04:59:59


Subscription    : Resilient Storage (8 sockets)
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90c041408684b60140868738d1006a
Limits:
    [ Sockets: 8 ]
Start Date      : 2012/12/31 05:00:00
End Date        : 2013/12/31 04:59:59


Subscription    : High-Availability (8 sockets)
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90c041408684b60140868738790055
Limits:
    [ Sockets: 8 ]
Start Date      : 2012/12/31 05:00:00
End Date        : 2013/12/31 04:59:59



# headpin -u admin -p **** system subscribe --pool 8a90c041408684b6014086873902007d --org ACME_Corporation --name dell-pe840-01.rhts.eng.bos.redhat.com
Runtime Error null at org.candlepin.audit.Event.<init>:151



Actual results:


Expected results:


Additional info:

--- Additional comment from Adam Price on 2013-08-20 14:32:33 EDT ---

i am unable to reproduce. could you try again and make sure this is still broken, or provide more detailed steps to reproduce? Thanks!

--- Additional comment from Tazim Kolhar on 2013-08-21 01:02:47 EDT ---


# headpin -u admin -p admin provider import_manifest --name 'Red Hat' --org ACME_Corporation --file '/tmp/manifest_org_sla.zip' --force
Provider [ Red Hat ] manifest import complete

# headpin -u admin -p admin org subscriptions --name ACME_Corporation
--------------------------------------------------------------------------------
                          Organization's Subscriptions
--------------------------------------------------------------------------------

Subscription    : Resilient Storage (8 sockets)
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90c041409f37ef01409f3ad9160065
Limits:
    [ Sockets: 8 ]
Start Date      : 2012/12/31 05:00:00
End Date        : 2013/12/31 04:59:59


Subscription    : Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90c041409f37ef01409f3ad8ee0053
Limits:
    [ Sockets: 2 ]
Start Date      : 2012/12/31 05:00:00
End Date        : 2013/12/31 04:59:59


Subscription    : High-Availability (8 sockets)
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90c041409f37ef01409f3ad8860042
Limits:
    [ Sockets: 8 ]
Start Date      : 2012/12/31 05:00:00
End Date        : 2013/12/31 04:59:59


# subscription-manager register --org="ACME_Corporation"
This system is already registered. Use --force to override
[root@dell-pe840-01 ~]# subscription-manager register --org="ACME_Corporation" --force
Username: admin
Password: 
The system has been registered with id: 9034a934-c93c-4023-9828-9b32d80171e9 

# headpin -u admin -p admin system subscribe --pool 8a90c041409f37ef01409f3ad8860042 --org ACME_Corporation --name dell-pe840-01.rhts.eng.bos.redhat.com
Runtime Error null at org.candlepin.audit.Event.<init>:151

--- Additional comment from Tazim Kolhar on 2013-08-21 01:10:06 EDT ---

Please refer the latest test report :

- http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/qe-headpin/job/official-sam-cli/17/ReportNG_Report/


Class : com.redhat.qe.katello.tests.cli.OrgTests
Method : test_SLAOrg

--- Additional comment from Tazim Kolhar on 2013-08-21 04:38:02 EDT ---

facing this issue on RHEL version

# cat /etc/issue
Red Hat Enterprise Linux Server release 6.4 (Santiago)
Kernel \r on an \m
Comment 6 Hayk Hovsepyan 2013-09-17 09:35:54 EDT
Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
openldap-2.4.23-31.el6.x86_64
katello-configure-1.4.5-7.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.11.alpha.el6sat.noarch
pulp-nodes-parent-2.3.0-0.11.alpha.el6sat.noarch
katello-common-1.4.6-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-2.el6sat.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
Katello-Katello-Configuration-KatelloClient-1.1-50.noarch
foreman-postgresql-1.2.1003-1.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-9.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.11.alpha.el6sat.noarch
katello-agent-1.4.4-2.el6sat.noarch
foreman-proxy-1.2.10003-1.el6sat.noarch
katello-cli-common-1.4.3-12.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-configure-foreman-proxy-1.4.5-7.el6sat.noarch
pulp-server-2.3.0-0.11.alpha.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.11.alpha.el6sat.noarch
pulp-nodes-common-2.3.0-0.11.alpha.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
signo-katello-0.0.20-2.el6sat.noarch
katello-glue-candlepin-1.4.6-2.el6sat.noarch
katello-glue-pulp-1.4.6-2.el6sat.noarch
katello-1.4.6-2.el6sat.noarch
katello-configure-foreman-1.4.5-7.el6sat.noarch
candlepin-0.8.25-1.el6sam.noarch
signo-0.0.20-2.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-foreman-all-1.4.6-2.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
foreman-1.2.1003-1.noarch
katello-cli-1.4.3-12.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
katello-certs-tools-1.4.3-2.el6sat.noarch
pulp-selinux-2.3.0-0.11.alpha.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-all-1.4.6-2.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-dhara.usersys.redhat.com-1.0-1.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 7 Bryan Kearney 2014-04-24 13:11:22 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 8 Bryan Kearney 2014-04-24 13:12:16 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.