Bug 999547 - redhat-support-plugin-rhev cannot be installed in unattended mode
redhat-support-plugin-rhev cannot be installed in unattended mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Spenser Shumaker
Spenser Shumaker
subeng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 10:21 EDT by Alex Lourie
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.3.0-7
Doc Type: Bug Fix
Doc Text:
redhat-support-plugin-rhev could not be installed in unattended mode. Upon running setup, it would ask a question regarding using proxy: "Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server?" There was no parameter to allow skipping this question. This was because the implementation provided an answerfile parameter to ignore setting up a proxy, but it didn't check it's value before it continued. The new implementation checks the value of this environment variable and will only proceed if it is set to True. Additionally, it updates a code considering the value of this parameter.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:58:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lourie 2013-08-21 10:21:08 EDT
Description of problem:

redhat-support-plugin-rhev cannot be installed in unattended mode. Upon running setup, it will ask a question regarding using proxy:

    Would you like transactions from the Red Hat Access Plugin sent from the RHEV  Manager to be brokered through a proxy server?

There is no parameter to allow skipping this question.
Comment 4 Charlie 2013-11-27 20:34:25 EST
This bug is currently attached to errata RHBA-2013:15513. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:58:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0082.html

Note You need to log in before you can comment on or make changes to this bug.