Bug 999625 - mount does not appear to be correctly documented for default mount options
mount does not appear to be correctly documented for default mount options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Karel Zak
Branislav Blaškovič
:
Depends On:
Blocks: 1131523
  Show dependency treegraph
 
Reported: 2013-08-21 13:58 EDT by Scott McCarty
Modified: 2014-10-14 03:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: util-linux-ng-2.17.2-12.16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1131523 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:34:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott McCarty 2013-08-21 13:58:51 EDT
Description of problem:

The default behavior of mount does not appear to be correctly documented for to "acl" option. It appears the acl option is set by default. Also, there is third party documentation (Michael Jang's book to study for the RHCSA) that documents incorrectly that the "acl" option must be specified. This is not a critical flaw, but it does cause confusion for users studying for the RHCSA. Updating the man page would probably be the easiest resolution.

       defaults
              Use default options: rw, suid, dev, exec, auto, nouser, async, and relatime.

Version-Release number of selected component (if applicable):


How reproducible:

   Very reproducable

Steps to Reproduce:
1. cd /root
2. setfacl -m u:smccarty:r install.log
3. getfacl install.log

Actual results:

# file: install.log
# owner: root
# group: root
user::rw-
user:smccarty:r--
group::r--
mask::r--
other::r--

Expected results:

setfacl -m u:smccarty:r install.log
setfacl: install.log: Operation not supported

or update the man page


Additional info:
Comment 4 Karel Zak 2014-06-12 05:38:35 EDT
Note that 'acl' is not VFS mount option (generic mount option), so it does not make sense to add it to the description for the 'default'. 

The 'acl' is filesystem specific and it's enabled pre-filesystem (for example according to info in FS superblock). See for example for extN:

# tune2fs -l /dev/sda4 | grep options
Default mount options:    user_xattr acl

I have added a hint about this to the mount.8 man page rathe than hardcode anything about 'acl' there.
Comment 7 errata-xmlrpc 2014-10-14 03:34:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1545.html

Note You need to log in before you can comment on or make changes to this bug.