Bug 999656 - splitting the sos report to modules - Heat
splitting the sos report to modules - Heat
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-heat (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: Milestone3
: Havana
Assigned To: Jeff Peeler
Amit Ugol
:
Depends On:
Blocks: 999587
  Show dependency treegraph
 
Reported: 2013-08-21 15:32 EDT by lpeer
Modified: 2016-04-26 22:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 999653
: 999657 (view as bug list)
Environment:
Last Closed: 2014-12-10 17:55:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lpeer 2013-08-21 15:32:18 EDT
Description of problem:

Using component naming instead of a single product naming could help make the sos plugin easier to maintain.

Instead of having -
 https://github.com/sosreport/sosreport/blob/master/sos/plugins/openstack.py

We should have module per component: nova, neutron, heat, ceilometer, glance, etc, etc

Other relevant information can be found on the thread -
http://post-office.corp.redhat.com/archives/rh-openstack-dev/2013-August/msg00364.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from lpeer on 2013-08-21 15:27:46 EDT ---

please create openstack-heat.py
Comment 1 Jeff Peeler 2013-08-27 15:21:31 EDT
Pull request made: https://github.com/sosreport/sosreport/pull/190
Comment 2 Jeff Peeler 2014-07-23 12:21:46 EDT
The above pull request was merged on Sep 9, 2013. It's present in the master branch:

https://github.com/sosreport/sos/blob/master/sos/plugins/openstack_heat.py
Comment 3 Jeff Peeler 2014-12-10 17:55:01 EST
Closing under current release since this was completed long ago.

Note You need to log in before you can comment on or make changes to this bug.