Bug 999665 - [ERD] EAP62_1120 [RFE] New log file on restart
[ERD] EAP62_1120 [RFE] New log file on restart
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: EAP 6.2.0
Assigned To: James Perkins
Petr Kremensky
Russell Dickenson
:
Depends On: 994700
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 15:44 EDT by Brian Stansberry
Modified: 2013-12-15 11:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The `SizeRotationFileHandler` has a new attribute `RotateOnBoot` that will cause the file handler to create a new file on server restart.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:15:00 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1971 Major Resolved Add rotate-on-boot attribute to size-rotating-file-handler 2017-05-18 05:03 EDT

  None (edit)
Description Brian Stansberry 2013-08-21 15:44:15 EDT
Tracker issue for ERD item EAP62_1120 [RFE] New log file on restart
Comment 1 James Perkins 2013-08-27 18:59:39 EDT
Just a note because it's not explicitly indicated, this attribute will only be available on the size-rotating-file-handler which is not the default file handler used by the server.
Comment 2 Jason Greene 2013-09-05 13:57:27 EDT
994700 was merged
Comment 3 Petr Kremensky 2013-09-18 02:18:00 EDT
This is not yet done, see PRODMGT-290.
Comment 4 Petr Kremensky 2013-09-19 04:04:56 EDT
James, can you please finish this by Friday Sep 20th (ER3 freeze) as ER3 is Beta release and should be feature complete. 
Thanks.
Comment 5 James Perkins 2013-09-19 11:39:56 EDT
Indeed. It will be done today actually. I have it working locally, just cleaning it up a bit before I send the PR in.
Comment 7 Petr Kremensky 2013-09-25 08:39:59 EDT
Verified on EAP 6.2.0.ER3.
Comment 12 JBoss JIRA Server 2013-10-18 16:18:33 EDT
James Perkins <jperkins@redhat.com> made a comment on jira WFLY-1971

Pull request merged

Note You need to log in before you can comment on or make changes to this bug.