Bug 999694 - [RFE] Visually group VMs in a list with color coding or similar
[RFE] Visually group VMs in a list with color coding or similar
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
---
x86_64 Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Moran Goldboim
Pavel Stehlik
: FutureFeature, UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 17:28 EDT by Kevin Clevenger
Modified: 2017-05-15 02:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-15 02:31:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Comment 1 Itamar Heim 2013-08-21 21:45:15 EDT
please provide more details/exmaple
Comment 4 Yaniv Lavi 2015-04-07 03:46:52 EDT
How complex will it be to add this?
Comment 5 Einav Cohen 2015-04-07 11:38:45 EDT
(In reply to Yaniv Dary from comment #4)
> How complex will it be to add this?

This needs to be discussed with the UXD team first, to see whether the user-experience design suggested here is valid and makes sense. 

To me personally - this doesn't necessarily make sense as-is, since we already have tags that allow us to, well, tag objects. I am not sure if we should create another completely-separate tagging-mechanism using colors. 

What I would consider is to allow associating tags with colors. 
Let's say that I have tag1 and I associate it with the 'blue' color. 
I would automatically paint blue the following: 
(a) 'tag1' itself (i.e. in the tags view or similar). 
(b) any object that is tagged with 'tag1' or with a descendant of 'tag1'. 
(c) any object that is associated with an object in (b) [e.g. if (b) contains 'host1' and 'VM1' runs on or pinned to 'host1' at the moment, 'VM1' will need to be colored as well]

Regardless of whether we are hooking into the existing tags mechanism or not, we need to create a UI and backend for associating an object with a color (or for associating a tag with a color), a logic for determining color for every object in the system, i.e. 'is this object colored or associated with any other colored object in the system?' (would have to be in the db-view level per object type or something similar - I don't see how this can be optimized performance-wise otherwise) and add UI support for colored grid-rows. 

From my perspective, this seems rather complex and should not be considered to any release earlier than 4.0. I also imagine that I would need some assistance for backend/db-related items.
Comment 8 Logan Kuhn 2017-03-21 09:21:39 EDT
This would help our environment too.  Another option that isn't quite as visually striking would be to add another column that shows what it's tagged.
Comment 9 Oved Ourfali 2017-05-15 02:31:51 EDT
This isn't conforming to UXD principles.
Closing as wontfix.
You can use the search to filter those out.

Note You need to log in before you can comment on or make changes to this bug.