Bug 999707 - pam fails to properly handle env variables when launching gui apps from root
pam fails to properly handle env variables when launching gui apps from root
Status: CLOSED DUPLICATE of bug 753882
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
18
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 18:00 EDT by The PowerTool
Modified: 2013-08-22 03:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 03:07:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Session log during documented failure (1.42 MB, text/x-log)
2013-08-21 18:00 EDT, The PowerTool
no flags Details

  None (edit)
Description The PowerTool 2013-08-21 18:00:30 EDT
Created attachment 789004 [details]
Session log during documented failure

Description of problem:
Apparent system crash: actual system lock-up (system still running and accessible via ssh)

Version-Release number of selected component (if applicable):
Fedora 18

How reproducible:


Steps to Reproduce:
1. Log in as normal user in gnome under Fedora 18
2. start a terminal session
3. su -
4. enter gedit on CL

Actual results:

]$ ls -la /run/user/1000/dconf/
-rw-------  1 root    root      2 Aug 21 17:52 user

subsequent system lock because current user doesn't have access

Expected results:

]$ ls -la /run/user/1000/dconf/
-rw-------  1 username    username      2 Aug 21 17:52 user

system continues to operate normally because current-user is owner

Additional info:
session log will display:
gnome-session[7489]: CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
Comment 1 Tomas Mraz 2013-08-22 03:07:36 EDT

*** This bug has been marked as a duplicate of bug 753882 ***

Note You need to log in before you can comment on or make changes to this bug.