Bug 999711 - Roles can be assigned only in some flows and not others when adding user groups
Roles can be assigned only in some flows and not others when adding user groups
Status: CLOSED DUPLICATE of bug 650915
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
unspecified
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Andrew Cathrow
yeylon@redhat.com
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 18:06 EDT by Kevin Clevenger
Modified: 2016-04-18 02:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 02:29:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Itamar Heim 2013-08-21 21:39:44 EDT
andrew - i remember there was some concern about confusing admins on ability to only add system roles or something like that?
Comment 2 Einav Cohen 2013-08-28 11:11:26 EDT
need to keep in mind that you cannot associate a user with a Role;
you can associate a user with a Role on a certain object.

in the "system permissions" dialog (available via the "Configure" section), it is fairly clear that the "certain object" is "System".

The main goal of the "Add User(s)" dialog is to add user(s) to the system in general, without permissions in mind.
We can add an option within the "Add User(s)" dialog to associate these newly-added users with system permissions, but it should be very clear that these are *system* permissions.

BTW, the appropriate location for adding the "add system permissions" action is the permissions sub-tab in the users main tab (see bug 650915), however it won't allow you deal with multiple users at once - only with the user selected in the main grid (on which we are showing the sub-tab details).
Comment 3 Itamar Heim 2013-08-29 02:29:30 EDT
since request here is about system permissions, closing as duplicate.

*** This bug has been marked as a duplicate of bug 650915 ***

Note You need to log in before you can comment on or make changes to this bug.