Bug 999749 - [RFE] should add a item to specify the backing file format when use qemu-img info to check it
[RFE] should add a item to specify the backing file format when use qemu-img ...
Status: CLOSED DUPLICATE of bug 1010610
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Max Reitz
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 22:44 EDT by Sibiao Luo
Modified: 2014-03-21 05:33 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-21 05:33:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-08-21 22:44:19 EDT
Description of problem:
rhel6 have no specified the backing file format after create snapshot when use qemu-img info to check it, but rhel7.0 has it.

Version-Release number of selected component (if applicable):
host info:
2.6.32-412.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.for rhel6.5:
# qemu-img create -f qcow2 -b data-disk.qcow2 -F qcow2 sluo-snapshot
Formatting 'sluo-snapshot', fmt=qcow2 size=10737418240 backing_file='data-disk.qcow2' backing_fmt='qcow2' encryption=off cluster_size=65536 
# qemu-img info sluo-snapshot 
image: sluo-snapshot
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 196K
cluster_size: 65536
backing file: data-disk.qcow2
2.for rhel7.0:
# qemu-img create -f qcow2 -b data-disk.qcow2 -F qcow2 sluo-snapshot
Formatting 'sluo-snapshot', fmt=qcow2 size=1073741824 backing_file='data-disk.qcow2' backing_fmt='qcow2' encryption=off cluster_size=65536 lazy_refcounts=off 
# qemu-img info sluo-snapshot 
image: sluo-snapshot
file format: qcow2
virtual size: 1.0G (1073741824 bytes)
disk size: 196K
cluster_size: 65536
backing file: data-disk.qcow2
backing file format: qcow2           <------------------here

Actual results:

Expected results:
should add a item to specify the backing file format when use qemu-img info to check it.

Additional info:
Comment 2 Max Reitz 2014-03-21 00:07:18 EDT
This is fixed for me since the backport of c054b3fd78f28b12f4d066583fc0ade017752479 (2ecf5c22465ffcfad3cad70b8c634703f0e9cfbb downstream), that is, as of version qemu-kvm-0.12.1.2-2.409.el6.

I'd propose closing this bug as WORKSFORME.
Comment 3 Kevin Wolf 2014-03-21 05:33:26 EDT
I think the usual resolution in such cases is DUPLICATE. Closing.

*** This bug has been marked as a duplicate of bug 1010610 ***

Note You need to log in before you can comment on or make changes to this bug.