Bug 999773 - quota: warning messages in nfs.log
quota: warning messages in nfs.log
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Manikandan
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 01:37 EDT by Saurabh
Modified: 2016-09-20 00:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 07:05:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-22 01:37:06 EDT
Description of problem:
while creating data inside a directory having quota limit set.
I have lot of "W" messages if I put the quotad down.

Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-fuse-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-3.4.0.20rhsquota1-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a 6x2 volume, start it
2. enable quota on the volume
3. mount over nfs
4. create a dir
5. set quota on the dir
6. start creating data inside the dir
7. kill the quotad meanwhile
8. check nfs.log

Actual results:
[2013-08-22 00:59:56.838412] W [client-rpc-fops.c:2058:client3_3_create_cbk] 0-dist-rep3-client-4: remote operation failed: Transport endpoint is
 not connected. Path: /dir1/1024
[2013-08-22 00:59:57.038801] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or dir
ectory
[2013-08-22 00:59:57.047410] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or dir
ectory
[2013-08-22 00:59:57.050287] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.052601] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.054754] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.061603] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.065245] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.068953] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.074979] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.075515] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.084709] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.084925] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.085066] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.093036] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.102059] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.110842] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.111586] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory
[2013-08-22 00:59:57.111952] W [client-rpc-fops.c:1579:client3_3_finodelk_cbk] 0-dist-rep3-client-4: remote operation failed: No such file or directory


Expected results:
These warning messages may give correct idea about the things thats going, 
it will be better if we can get over them.

Additional info:
Comment 2 Vivek Agarwal 2013-10-17 05:18:58 EDT
Per bug triage, removing this from u1.
Comment 3 Manikandan 2015-08-13 07:05:19 EDT
With the latest version, I am not able to reproduce the bug. So closing the bug.

Note You need to log in before you can comment on or make changes to this bug.