Bug 999785 - requires happybase
requires happybase
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Eoghan Glynn
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 02:35 EDT by Ian Wienand
Modified: 2016-04-26 15:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 02:33:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Wienand 2013-08-22 02:35:15 EDT
I'm trying to get ceilometer working with firestack/smokestack

unfortunately it bails with

---
[root@nova1 ~]# /usr/bin/ceilometer-api --config-file /etc/ceilometer/ceilometer.conf 
2013-08-22 06:32:28.529 15253 ERROR stevedore.extension [-] Could not load 'mongodb': happybase>=0.4
2013-08-22 06:32:28.543 15253 ERROR stevedore.extension [-] happybase>=0.4
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension Traceback (most recent call last):
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension   File "/usr/lib/python2.6/site-packages/stevedore/extension.py", line 75, in _load_plugins
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension     invoke_kwds,
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension   File "/usr/lib/python2.6/site-packages/stevedore/named.py", line 44, in _load_one_plugin
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension     ep, invoke_on_load, invoke_args, invoke_kwds,
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension   File "/usr/lib/python2.6/site-packages/stevedore/extension.py", line 87, in _load_one_plugin
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension     plugin = ep.load()
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1947, in load
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension     if require: self.require(env, installer)
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1960, in require
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension     working_set.resolve(self.dist.requires(self.extras),env,installer))
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension     raise DistributionNotFound(req)
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension DistributionNotFound: happybase>=0.4
2013-08-22 06:32:28.543 15253 TRACE stevedore.extension 
2013-08-22 06:32:28.592 15253 CRITICAL ceilometer [-] No 'ceilometer.storage' driver found, looking for 'mongodb'
---

i guess because happybase is in the requirements.  

As far as i can see, python-happybase isn't packaged.  Is the solution to just patch this requirement out in the .spec file in [1]?  or is there another way around this?

[1] https://github.com/redhat-openstack/openstack-ceilometer
Comment 2 Pádraig Brady 2013-08-26 06:47:45 EDT
eglynn will know better, but I think we're not supporting hbase at this time.
Hence it's best to adjust requirements.txt
In fact as will all python projects and all openstack projects at least,
it's best to avoid runtime python dep management which is already catered
for by rpm and possibly different anyway in our (patched) environment.
So the technique we've been using in %prep is to rm -f requirements.txt
Comment 3 Ian Wienand 2013-08-27 02:33:04 EDT
yeah, avoiding requirements.txt means stevedore doesn't get involved.  Thanks for the tip

Note You need to log in before you can comment on or make changes to this bug.