Bug 999802 - Min paramter in manifest file is not working while creating a scaling app
Min paramter in manifest file is not working while creating a scaling app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 03:32 EDT by Ma xiaoqiang
Modified: 2016-07-03 20:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:23:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-08-22 03:32:12 EDT
Description of problem:
Change the MIN setting for a cartridge to 2 in the manifest file, and Max to 4; Create a scalable app,but the gear's number is still 1.

Version-Release number of selected component (if applicable):
devenv_3684

How reproducible:
always

Steps to Reproduce:
1. Change the Min setting for perl cartridge to 2,and Max to 4;
#vim /usr/libexec/openshift/cartridges/perl/metadata/manifest.yml
2.clear the cache on broker, then reboot the broker server and node server     
#oo-admin-broker-cache -c --console
3.create a scalable app with perl cartridge.
#rhc app create perlapp  perl -s
4.check the status of app
#rhc app show --gears perlapp 

Actual results:
only one gear is started
ID                               State   Cartridges            Size  SSH URL
-------------------------------- ------- --------------------- ----- --------------------------------------------------------------
0245861a0af611e3bc2c22000ab3150e started perl-5.10 haproxy-1.4 small 0245861a0af611e3bc2c22000ab3150e@xiaom13-xiaom.dev.rhcloud.com
Expected results:
The gear's number should be 2  


Additional info:
the Max setiing is working 
The Minnum is 2;but the num of gear is 1
# rhc app show  perlapp        
perlapp @ http://perlapp-xiaom.dev.rhcloud.com/ (uuid: 0245861a0af611e3bc2c22000ab3150e)
----------------------------------------------------------------------------------------
  Domain:  xiaom
  Created: 2:42 PM
  Gears:   2 (defaults to small)
  Git URL: ssh://0245861a0af611e3bc2c22000ab3150e@perlapp-xiaom.dev.rhcloud.com/~/git/perlapp.git/
  SSH:     0245861a0af611e3bc2c22000ab3150e@perlapp-xiaom.dev.rhcloud.com
  perl-5.10 (Perl 5.10)
  ---------------------
    Scaling: x2 (minimum: 2, maximum: 4) on small gears
  haproxy-1.4 (OpenShift Web Balancer)
  ------------------------------------
Comment 1 Johnny Liu 2013-10-30 05:38:30 EDT
Looks like this is working in devenv_3966, seen from mcollective log, Min value takes effect, and it is creating 2 gears. But due to BZ#1024698, app is failed to created.
Comment 2 Johnny Liu 2013-10-31 01:40:56 EDT
According to comment 1, move this bug to ON_QA.
Comment 3 Johnny Liu 2013-10-31 02:04:32 EDT
Verified this bug with devenv_devenv_3973, and PASS.

Set Min to 2, Max to 10 in maifest file, then create scalable app, app could be created successfully.

$ rhc domain show -p redhat
Domain jialiu
-------------
  Created:            1:26 PM
  Allowed Gear Sizes: small

  scaphp53app @ http://scaphp53app-jialiu.dev.rhcloud.com/ (uuid: 5271ea0cdefea7db1e000006)
  -----------------------------------------------------------------------------------------
    Domain:  jialiu
    Created: 1:26 PM
    Gears:   2 (defaults to small)
    Git URL: ssh://5271ea0cdefea7db1e000006@scaphp53app-jialiu.dev.rhcloud.com/~/git/scaphp53app.git/
    SSH:     5271ea0cdefea7db1e000006@scaphp53app-jialiu.dev.rhcloud.com

    php-5.3 (PHP 5.3)
    -----------------
      Scaling: x2 (minimum: 2, maximum: 10) on small gears

    haproxy-1.4 (Web Load Balancer)
    -------------------------------
      Gears: Located with php-5.3

You have 1 application in your domain.

$ rhc app show -a scaphp53app --gears -predhat
ID                       State   Cartridges          Size  SSH URL
------------------------ ------- ------------------- ----- ------------------------------------------------------------------------
5271ea0cdefea7db1e000006 started php-5.3 haproxy-1.4 small 5271ea0cdefea7db1e000006@scaphp53app-jialiu.dev.rhcloud.com
851962571337641431662592 started php-5.3 haproxy-1.4 small 851962571337641431662592@851962571337641431662592-jialiu.dev.rhcloud.com
Comment 4 Johnny Liu 2013-10-31 02:27:26 EDT
Forget to confirm with developers, so I move this back to it original status.

From QE side, this bug is fixed, if devel also think it is already fixed, pls move it to ON_QA status.
Comment 5 Abhishek Gupta 2013-11-06 14:19:57 EST
If this is already fixed and verified. please go ahead and mark it verified/closed.
Comment 6 Ma xiaoqiang 2013-11-06 20:12:48 EST
check on puddle [2.0-2013-11-05.1]
# rhc app create test1  https://raw.github.com/xiama/pythoncartri/master/metadata/manifest.yml -s
# rhc app show test1 --gears
ID                       State   Cartridges                   Size  SSH URL
------------------------ ------- ---------------------------- ----- -----------------------------------------------------------------------
527ae5ffab6546400a000001 started xiama-python-2.6 haproxy-1.4 small 527ae5ffab6546400a000001@test1-xiaom.ose-1105.com.cn
527ae5ffab6546400a000006 started xiama-python-2.6 haproxy-1.4 small 527ae5ffab6546400a000006@527ae5ffab6546400a000006-xiaom.ose-1105.com.cn
# rhc app show test1 
test1 @ http://test1-xiaom.ose-1105.com.cn/ (uuid: 527ae5ffab6546400a000001)
----------------------------------------------------------------------------
  Domain:     xiaom
  Created:    5:59 PM
  Gears:      2 (defaults to small)
  Git URL:    ssh://527ae5ffab6546400a000001@test1-xiaom.ose-1105.com.cn/~/git/test1.git/
  SSH:        527ae5ffab6546400a000001@test1-xiaom.ose-1105.com.cn
  Deployment: auto (on git push)

  xiama-python-2.6 (Python 2.6)
  -----------------------------
    From:    https://raw.github.com/xiama/pythoncartri/master/metadata/manifest.yml
    Scaling: x2 (minimum: 2, maximum: 4) on small gears
Comment 7 Ma xiaoqiang 2013-11-06 20:43:33 EST
(In reply to Ma xiaoqiang from comment #6)
> check on puddle [2.0-2013-11-05.1]
> # rhc app create test1 
> https://raw.github.com/xiama/pythoncartri/master/metadata/manifest.yml -s
> # rhc app show test1 --gears
> ID                       State   Cartridges                   Size  SSH URL
> ------------------------ ------- ---------------------------- -----
> -----------------------------------------------------------------------
> 527ae5ffab6546400a000001 started xiama-python-2.6 haproxy-1.4 small
> 527ae5ffab6546400a000001@test1-xiaom.ose-1105.com.cn
> 527ae5ffab6546400a000006 started xiama-python-2.6 haproxy-1.4 small
> 527ae5ffab6546400a000006@527ae5ffab6546400a000006-xiaom.ose-1105.com.cn
> # rhc app show test1 
> test1 @ http://test1-xiaom.ose-1105.com.cn/ (uuid: 527ae5ffab6546400a000001)
> ----------------------------------------------------------------------------
>   Domain:     xiaom
>   Created:    5:59 PM
>   Gears:      2 (defaults to small)
>   Git URL:   
> ssh://527ae5ffab6546400a000001@test1-xiaom.ose-1105.com.cn/~/git/test1.git/
>   SSH:        527ae5ffab6546400a000001@test1-xiaom.ose-1105.com.cn
>   Deployment: auto (on git push)
> 
>   xiama-python-2.6 (Python 2.6)
>   -----------------------------
>     From:   
> https://raw.github.com/xiama/pythoncartri/master/metadata/manifest.yml
>     Scaling: x2 (minimum: 2, maximum: 4) on small gears


check it on devenv_3998
# rhc app create phps php-5.3 -s
# rhc app show phps --gears
ID                       State   Cartridges          Size  SSH URL
------------------------ ------- ------------------- ----- -----------------------------------------------------------------------
527aef549d108cc579000005 started php-5.3 haproxy-1.4 small 527aef549d108cc579000005@phps-xiaom.dev.rhcloud.com
187863129393282555052032 started php-5.3 haproxy-1.4 small 187863129393282555052032@187863129393282555052032-xiaom.dev.rhcloud.com
# rhc app show phps     
php-5.3 (PHP 5.3)
  -----------------
    Scaling: x2 (minimum: 2, maximum: 3) on small gears

Note You need to log in before you can comment on or make changes to this bug.