Bug 999845 - Unavailable artifacts referenced in the jboss-javaee-6.0-with-hibernate-1.0.4.Final-redhat-9.pom BOM
Unavailable artifacts referenced in the jboss-javaee-6.0-with-hibernate-1.0.4...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: ER3
: EAP 6.2.0
Assigned To: Paul Gier
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks: eap62-beta-blockers
  Show dependency treegraph
 
Reported: 2013-08-22 05:07 EDT by Nikoleta Ziakova
Modified: 2013-12-15 11:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:14:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test pom file (2.53 KB, application/xml)
2013-08-30 02:59 EDT, Nikoleta Ziakova
no flags Details
Output for test pom file (29.81 KB, text/plain)
2013-08-30 03:04 EDT, Nikoleta Ziakova
no flags Details
Modified test pom file (2.54 KB, application/xml)
2013-08-30 03:08 EDT, Nikoleta Ziakova
no flags Details

  None (edit)
Description Nikoleta Ziakova 2013-08-22 05:07:02 EDT
Description of problem:
This is problem for customers and layered products, they are not able to get all supported jars from maven repo zip.
BOM jboss-javaee-6.0-with-hibernate is listed in EAP 6.1.1 Maven BOM Usage document - https://docspace.corp.redhat.com/docs/DOC-153970
 
I used this BOM from customer perspective and imported all supported/defined dependencies into my testing pom file. I executed dependency:tree goal for maven to get supported jars. The result is failure, I can't get expected files. I was using maven repo zip and central.
 
Problematic artifacts:
org.hibernate:hibernate-c3p0:jar:4.2.0.SP1-redhat-1
org.hibernate:hibernate-ehcache:jar:4.2.0.SP1-redhat-1
org.hibernate:hibernate-proxool:jar:4.2.0.SP1-redhat-1

Version-Release number of selected component:
EAP 6.1.1. ER7
Comment 1 Paul Gier 2013-08-22 09:33:21 EDT
Interesting, I'm not sure why these dependencies are managed but don't seem to be used by the quickstarts.  This might be a question for the JDF team.
Comment 2 Nikoleta Ziakova 2013-08-29 09:50:17 EDT
This should be included in EAP 6.1.1 Release Notes as a Known Issue
Comment 3 sgilda 2013-08-29 15:21:56 EDT
Nikoleta: can you attach your test pom.xml file and the output of your dependency tree? We need to determine what is requesting the missing artifacts.

You are using this differently that a customer because you are attempting to load everything. The missing artifact may be so obscure it will never be used.

I spoke with Paul Gier and we don't believe we need to release note this. It's probably been like this since 6.1 and no one has hit the issue.
Comment 4 Scott Mumford 2013-08-29 19:19:43 EDT
Marking for exclusion from Release Notes as per comment 3.
Comment 5 Nikoleta Ziakova 2013-08-30 02:59:50 EDT
Created attachment 792042 [details]
Test pom file
Comment 6 Nikoleta Ziakova 2013-08-30 03:04:51 EDT
Created attachment 792047 [details]
Output for test pom file

Output of command:
mvn -X -U -e -s settings-with-central.xml -f jboss-javaee-6.0-with-hibernate-1.0.4.Final-redhat-9.pom-test-pom dependency:tree

Error message:
[ERROR] Failed to execute goal on project repo-test: Could not resolve dependencies for project org.jboss.test:repo-test:jar:1.0.0: The following artifacts could not be resolved: org.infinispan:infinispan-core:jar:5.2.6.Final-redhat-1, org.hibernate:hibernate-c3p0:jar:4.2.0.SP1-redhat-1, org.hibernate:hibernate-ehcache:jar:4.2.0.SP1-redhat-1, org.hibernate:hibernate-proxool:jar:4.2.0.SP1-redhat-1

Dependency tree:
[DEBUG] org.jboss.test:repo-test:jar:1.0.0
[DEBUG]    org.hibernate:hibernate-core:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]       org.jboss.logging:jboss-logging:jar:3.1.2.GA-redhat-1:compile
[DEBUG]       org.javassist:javassist:jar:3.15.0-GA-redhat-2:compile
[DEBUG]       antlr:antlr:jar:2.7.7-redhat-2:compile
[DEBUG]       org.jboss.spec.javax.transaction:jboss-transaction-api_1.1_spec:jar:1.0.1.Final-redhat-2:compile
[DEBUG]       dom4j:dom4j:jar:1.6.1-redhat-5:compile
[DEBUG]       xml-resolver:xml-resolver:jar:1.2-redhat-2:compile
[DEBUG]       org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.1.Final-redhat-2:compile
[DEBUG]       org.hibernate.common:hibernate-commons-annotations:jar:4.0.1.Final-redhat-2:compile
[DEBUG]    org.hibernate:hibernate-entitymanager:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-envers:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-infinispan:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]       org.rhq.helpers:rhq-pluginAnnotations:jar:3.0.4-redhat-2:compile
[DEBUG]       org.infinispan:infinispan-core:jar:5.2.6.Final-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-c3p0:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-ehcache:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-proxool:jar:4.2.0.SP1-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-validator:jar:4.3.1.Final-redhat-1:compile
[DEBUG]       javax.validation:validation-api:jar:1.0.0.GA-redhat-2:compile
[DEBUG]    org.hibernate:hibernate-search:jar:4.2.0.Final:compile
[DEBUG]    org.hibernate:hibernate-search-analyzers:jar:4.2.0.Final:compile
[DEBUG]       org.apache.lucene:lucene-core:jar:3.6.2:compile
[DEBUG]       org.apache.lucene:lucene-analyzers:jar:3.6.2:compile
[DEBUG]       org.apache.solr:solr-analysis-extras:jar:3.6.2:compile
[DEBUG]          org.apache.solr:solr-core:jar:3.6.2:compile
[DEBUG]             org.apache.solr:solr-solrj:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-highlighter:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-kuromoji:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-memory:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-misc:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-phonetic:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-spatial:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-spellchecker:jar:3.6.2:compile
[DEBUG]             org.apache.lucene:lucene-grouping:jar:3.6.2:compile
[DEBUG]             commons-codec:commons-codec:jar:1.6:compile
[DEBUG]             commons-io:commons-io:jar:2.1:compile
[DEBUG]             commons-lang:commons-lang:jar:2.6:compile
[DEBUG]             com.google.guava:guava:jar:r05:compile
[DEBUG]          org.apache.lucene:lucene-smartcn:jar:3.6.2:compile
[DEBUG]          org.apache.lucene:lucene-stempel:jar:3.6.2:compile
[DEBUG]          org.slf4j:slf4j-api:jar:1.6.1:compile
[DEBUG]    org.hibernate:hibernate-search-engine:jar:4.2.0.Final:compile
[DEBUG]       org.apache.avro:avro:jar:1.6.3:compile
[DEBUG]          org.codehaus.jackson:jackson-core-asl:jar:1.8.8:compile
[DEBUG]          org.codehaus.jackson:jackson-mapper-asl:jar:1.8.8:compile
[DEBUG]          com.thoughtworks.paranamer:paranamer:jar:2.3:compile
[DEBUG]          org.xerial.snappy:snappy-java:jar:1.0.4.1:compile
[DEBUG]       org.apache.lucene:lucene-facet:jar:3.6.2:compile
[DEBUG]    org.hibernate:hibernate-search-infinispan:jar:4.2.0.Final:compile
[DEBUG]       org.infinispan:infinispan-lucene-directory:jar:5.1.8.Final:compile
[DEBUG]    org.hibernate:hibernate-search-orm:jar:4.2.0.Final:compile
[DEBUG]    org.hibernate:hibernate-validator-annotation-processor:jar:4.3.1.Final-redhat-1:compile
[DEBUG]    org.hibernate:hibernate-jpamodelgen:jar:1.2.0.Final:compile
Comment 7 Nikoleta Ziakova 2013-08-30 03:08:35 EDT
Created attachment 792050 [details]
Modified test pom file

Test pom file with problematic dependencies commented out.
Comment 8 Paul Gier 2013-09-24 15:25:54 EDT
For the new build, the BOM versions will match the EAP target release (6.2.0.Beta1, 6.2.0.GA, etc).  So the ER3 hibernate bom will have the version 6.2.0.Beta1.

I added a test to the maven repo build to verify these dependency resolutions.
http://git.app.eng.bos.redhat.com/?p=jboss-eap/maven-repository-testsuite.git;a=commitdiff;h=438be1bbf29f3eeaac1f8d8822b8e94968ac1e1c
Comment 9 Nikoleta Ziakova 2013-09-26 04:28:51 EDT
Verified for EAP 6.2.0 ER3

Note You need to log in before you can comment on or make changes to this bug.