Bug 999848 - Unavailable artifacts referenced in the jboss-javaee-6.0-with-infinispan-1.0.4.Final-redhat-9.pom BOM
Unavailable artifacts referenced in the jboss-javaee-6.0-with-infinispan-1.0....
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.2.0
Assigned To: Lin Gao
Nikoleta Ziakova
Russell Dickenson
: Documentation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 05:11 EDT by Nikoleta Ziakova
Modified: 2013-12-15 11:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:15:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test pom file (1.01 KB, application/xml)
2013-08-30 03:18 EDT, Nikoleta Ziakova
no flags Details
Output for test pom file (67.85 KB, text/plain)
2013-08-30 03:22 EDT, Nikoleta Ziakova
no flags Details
Modified test pom file (1.08 KB, application/xml)
2013-08-30 03:23 EDT, Nikoleta Ziakova
no flags Details
Test settings.xml file (1.39 KB, text/xml)
2013-10-22 04:05 EDT, Nikoleta Ziakova
no flags Details

  None (edit)
Description Nikoleta Ziakova 2013-08-22 05:11:08 EDT
Description of problem:
This is problem for customers and layered products, they are not able to get all supported jars from maven repo zip.
BOM jboss-javaee-6.0-with-infinispan is listed in EAP 6.1.1 Maven BOM Usage document - https://docspace.corp.redhat.com/docs/DOC-153970
 
I used this BOM from customer perspective and imported all supported/defined dependencies into my testing pom file. I executed dependency:tree goal for maven to get supported jars. The result is failure, I can't get expected files. I was using maven repo zip and central.
 
Problematic artifacts:
org.jboss:staxmapper:jar:1.1.0.Final

Version-Release number of selected component:
EAP 6.1.1. ER7
Comment 1 Nikoleta Ziakova 2013-08-29 09:51:23 EDT
This should be included in EAP 6.1.1 Release Notes as a Known Issue
Comment 2 sgilda 2013-08-29 14:16:05 EDT
Nikoleta: can you attach your test pom.xml file and the output of your dependency tree? We need to determine what is requesting the missing artifacts.

You are using this differently that a customer because you are attempting to load everything. The missing artifact may be so obscure it will never be used.

I spoke with Paul Gier and we don't believe we need to release note this. It's probably been like this since 6.1 and no one has hit the issue.
Comment 3 Scott Mumford 2013-08-29 19:19:12 EDT
Marking for exclusion from Release Notes as per comment 2.
Comment 4 Nikoleta Ziakova 2013-08-30 03:18:39 EDT
Created attachment 792056 [details]
Test pom file
Comment 5 Nikoleta Ziakova 2013-08-30 03:22:52 EDT
Created attachment 792058 [details]
Output for test pom file

Output of command:
mvn -X -U -e -s settings-with-central.xml -f jboss-javaee-6.0-with-infinispan-1.0.4.Final-redhat-9.pom-test-pom dependency:tree

Error message:
[ERROR] Failed to execute goal on project repo-test: Could not resolve dependencies for project org.jboss.test:repo-test:jar:1.0.0: Could not find artifact org.jboss:staxmapper:jar:1.1.0.Final

Dependency tree:
[DEBUG] org.jboss.test:repo-test:jar:1.0.0
[DEBUG]    org.infinispan:infinispan-core:jar:5.2.7.Final-redhat-1:compile
[DEBUG]       org.jgroups:jgroups:jar:3.2.7.Final:compile
[DEBUG]       org.jboss.spec.javax.transaction:jboss-transaction-api_1.1_spec:jar:1.0.1.Final-redhat-2:compile (version managed from 1.0.0.Final)
[DEBUG]       org.jboss.marshalling:jboss-marshalling-river:jar:1.3.15.GA:compile
[DEBUG]       org.jboss.marshalling:jboss-marshalling:jar:1.3.15.GA:compile
[DEBUG]       org.jboss.logging:jboss-logging:jar:3.1.1.GA:compile
[DEBUG]       org.jboss:staxmapper:jar:1.1.0.Final:compile
[DEBUG]    org.infinispan:infinispan-client-hotrod:jar:5.2.7.Final-redhat-1:compile
[DEBUG]       commons-pool:commons-pool:jar:1.6:compile
Comment 6 Nikoleta Ziakova 2013-08-30 03:23:30 EDT
Created attachment 792059 [details]
Modified test pom file

Test pom file with problematic dependencies commented out.
Comment 7 Nikoleta Ziakova 2013-10-04 04:30:15 EDT
Maven repo zip no longer contains jboss-javaee-6.0-with-infinispan BOM. This needs change in dev guide [1]. Please remove this BOM from Table 2.1. JBoss BOMs Used by the Quickstarts.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/Maven_BOM_Usage.html
Comment 8 Lin Gao 2013-10-22 03:22:56 EDT
From EAP 6.2, the artifact: jboss-javaee-6.0-with-infinispan has been moved from JBoss EAP BOM(https://github.com/jboss-developer/jboss-eap-boms) to JBoss Data Grid BOM(https://github.com/jboss-developer/jboss-jdg-bom), and the shipped EAP maven repository will not contain this artifact any longer.
Comment 9 Nikoleta Ziakova 2013-10-22 04:05:00 EDT
Created attachment 814882 [details]
Test settings.xml file
Comment 10 Paul Gier 2013-10-22 11:25:22 EDT
I verified that this bom is not currently used in any of the eap quickstarts, so it should be safe to remove from the eap boms project.
Comment 11 Lin Gao 2013-10-22 22:39:55 EDT
Close it as won't fix solution.

And I tested the jboss-jdg-bom(https://github.com/jboss-developer/jboss-jdg-bom) against jdg-maven-repository( downloaded from http://download.devel.redhat.com/devel/candidates/JDG/JDG-6.2.0.ER3/), and it succeeded, so there should be no problem in the latest jdg-bom at the moment.


[INFO] Building Maven repo tests 1.0.0
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-dependency-plugin:2.1:tree (default-cli) @ repo-test ---
[INFO] org.jboss.test:repo-test:jar:1.0.0
[INFO] +- org.infinispan:infinispan-core:jar:6.0.0.CR1:compile
[INFO] |  +- org.infinispan:infinispan-commons:jar:6.0.0.CR1:compile
[INFO] |  +- org.jgroups:jgroups:jar:3.4.0.Beta1:compile
[INFO] |  |  \- log4j:log4j:jar:1.2.14:compile
[INFO] |  +- org.jboss.spec.javax.transaction:jboss-transaction-api_1.1_spec:jar:1.0.1.Final:compile
[INFO] |  +- org.jboss.marshalling:jboss-marshalling-river:jar:1.3.18.GA:compile
[INFO] |  +- org.jboss.marshalling:jboss-marshalling:jar:1.3.18.GA:compile
[INFO] |  \- org.jboss.logging:jboss-logging:jar:3.1.2.GA:compile
[INFO] \- org.infinispan:infinispan-client-hotrod:jar:6.0.0.CR1:compile
[INFO]    \- commons-pool:commons-pool:jar:1.6:compile
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
Comment 12 Rostislav Svoboda 2013-11-14 09:08:29 EST
Verified on EAP 6.2.0 CR1.

jboss-javaee-6.0-with-infinispan BOM is not present in maven repo zip.

[rsvoboda@steve 620CR1]$ find . | grep jboss-javaee-6.0-with-infini

Note You need to log in before you can comment on or make changes to this bug.