Bug 999849 - Unavailable artifacts referenced in the jboss-javaee-6.0-with-errai-1.0.4.Final-redhat-9.pom BOM
Unavailable artifacts referenced in the jboss-javaee-6.0-with-errai-1.0.4.Fin...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.2.0
Assigned To: sgilda
Nikoleta Ziakova
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 05:12 EDT by Nikoleta Ziakova
Modified: 2017-10-09 20:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:17:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test pom file (2.10 KB, application/xml)
2013-08-30 03:26 EDT, Nikoleta Ziakova
no flags Details
Output for test pom file (831.94 KB, text/plain)
2013-08-30 03:28 EDT, Nikoleta Ziakova
no flags Details
Modified test pom file (2.11 KB, application/xml)
2013-08-30 03:28 EDT, Nikoleta Ziakova
no flags Details

  None (edit)
Description Nikoleta Ziakova 2013-08-22 05:12:20 EDT
Description of problem:
This is problem for customers and layered products, they are not able to get all supported jars from maven repo zip.
BOM jboss-javaee-6.0-with-errai is listed in EAP 6.1.1 Maven BOM Usage document - https://docspace.corp.redhat.com/docs/DOC-153970
 
I used this BOM from customer perspective and imported all supported/defined dependencies into my testing pom file. I executed dependency:tree goal for maven to get supported jars. The result is failure, I can't get expected files. I was using maven repo zip and central.
 
Problematic artifacts:
org.jboss.errai:jboss7-support:jar:2.2.0.Final

Version-Release number of selected component:
EAP 6.1.1. ER7
Comment 1 Nikoleta Ziakova 2013-08-29 09:52:26 EDT
This should be included in EAP 6.1.1 Release Notes as a Known Issue
Comment 2 Paul Gier 2013-08-29 11:43:54 EDT
Can you also paste the dependency tree for these failures?  That will make it easier to track down the cause.
Comment 3 sgilda 2013-08-29 15:21:23 EDT
I spoke with Paul Gier and we don't believe we need to release note this. It's probably been like this since 6.1 and no one has hit the issue.
Comment 4 Scott Mumford 2013-08-29 19:18:41 EDT
Marking for exclusion from Release Notes as per comment 3.
Comment 5 Nikoleta Ziakova 2013-08-30 03:26:15 EDT
Created attachment 792060 [details]
Test pom file
Comment 6 Nikoleta Ziakova 2013-08-30 03:28:13 EDT
Created attachment 792061 [details]
Output for test pom file

Output of command:
mvn -X -U -e -s settings-with-central.xml -f jboss-javaee-6.0-with-errai-1.0.4.Final-redhat-9.pom-test-pom dependency:tree

Error message:
[ERROR] Failed to execute goal on project repo-test: Could not resolve dependencies for project org.jboss.test:repo-test:jar:1.0.0: Could not find artifact org.jboss.errai:jboss7-support:jar:2.2.0.Final

Dependency tree:
[DEBUG] org.jboss.test:repo-test:jar:1.0.0
[DEBUG]    org.jboss.errai:errai-bus:jar:2.2.0.Final:compile
[DEBUG]       org.jboss.errai:errai-common:jar:2.2.0.Final:compile
[DEBUG]          org.jboss.errai.reflections:reflections:jar:2.2.0.Final:compile
[DEBUG]             dom4j:dom4j:jar:1.6.1:compile
[DEBUG]                xml-apis:xml-apis:jar:1.0.b2:compile
[DEBUG]       org.jboss.errai:errai-config:jar:2.2.0.Final:compile
[DEBUG]       org.jboss.errai:errai-marshalling:jar:2.2.0.Final:compile
[DEBUG]          org.jboss.errai:errai-codegen-gwt:jar:2.2.0.Final:compile
[DEBUG]       javax.validation:validation-api:jar:1.0.0.GA-redhat-2:compile (version managed from 1.0.0.GA)
[DEBUG]       javax.validation:validation-api:jar:sources:1.0.0.GA:compile
[DEBUG]       com.google.inject:guice:jar:3.0:compile
[DEBUG]          aopalliance:aopalliance:jar:1.0:compile
[DEBUG]       org.slf4j:slf4j-api:jar:1.6.1:compile
[DEBUG]       junit:junit:jar:4.8.1:compile
[DEBUG]       org.javassist:javassist:jar:3.15.0-GA:compile
[DEBUG]       org.jboss.errai.io.netty:netty:jar:4.0.0.Alpha1.errai.r1:compile
[DEBUG]       com.google.guava:guava:jar:12.0:compile
[DEBUG]          com.google.code.findbugs:jsr305:jar:1.3.9:compile
[DEBUG]    org.jboss.errai:errai-ioc:jar:2.2.0.Final:compile
[DEBUG]       org.jboss.errai:errai-codegen:jar:2.2.0.Final:compile
[DEBUG]       javax.enterprise:cdi-api:jar:1.0-SP4-redhat-2:compile (version managed from 1.0-SP4)
[DEBUG]          org.jboss.spec.javax.interceptor:jboss-interceptors-api_1.1_spec:jar:1.0.1.Final-redhat-2:compile
[DEBUG]          org.jboss.spec.javax.annotation:jboss-annotations-api_1.1_spec:jar:1.0.1.Final-redhat-2:compile
[DEBUG]    org.jboss.errai:errai-tools:jar:2.2.0.Final:compile
[DEBUG]       hsqldb:hsqldb:jar:1.8.0.7:compile
[DEBUG]    org.jboss.errai:errai-jaxrs-client:jar:2.2.0.Final:compile
[DEBUG]       org.jboss.resteasy:jaxrs-api:jar:2.3.5.Final:compile
[DEBUG]       com.google.guava:guava-gwt:jar:12.0:compile
[DEBUG]    org.jboss.errai:errai-jaxrs-provider:jar:2.2.0.Final:compile
[DEBUG]    org.jboss.errai:errai-cdi-client:jar:2.2.0.Final:compile
[DEBUG]    org.jboss.errai:errai-javax-enterprise:jar:2.2.0.Final:compile
[DEBUG]    org.jboss.errai:errai-weld-integration:jar:2.2.0.Final:compile
[DEBUG]       org.jboss.errai:errai-cdi-jetty:jar:2.2.0.Final:compile
[DEBUG]       org.jboss.weld.servlet:weld-servlet-core:jar:1.1.6.Final:compile
[DEBUG]          org.jboss.weld:weld-spi:jar:1.1.Final:compile
[DEBUG]             org.jboss.weld:weld-api:jar:1.1.Final:compile
[DEBUG]    org.jboss.errai:jboss7-support:jar:2.2.0.Final:compile
[DEBUG]    com.google.gwt:gwt-user:jar:2.4.0:compile
[DEBUG]    com.google.gwt:gwt-dev:jar:2.4.0:compile
[DEBUG]    org.mvel:mvel2:jar:2.1.Beta8:compile
Comment 7 Nikoleta Ziakova 2013-08-30 03:28:46 EDT
Created attachment 792062 [details]
Modified test pom file

Test pom file with problematic dependencies commented out.
Comment 8 Marek Novotny 2013-09-12 04:56:57 EDT
You should remove the jboss-javaee-6.0-with-errai BOM as it is targeting WFK product not EAP.
Comment 9 Nikoleta Ziakova 2013-10-04 04:28:36 EDT
Maven repo zip no longer contains jboss-javaee-6.0-with-errai BOM. This needs change in dev guide [1]. Please remove this BOM from Table 2.1. JBoss BOMs Used by the Quickstarts.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/Maven_BOM_Usage.html
Comment 10 Paul Gier 2013-10-21 13:12:53 EDT
Assigning to Sande to update the documentation with the correct list of BOMs.
Comment 11 sgilda 2013-10-21 13:17:10 EDT
Removed the BOM from the table in the doc.
Comment 13 Nikoleta Ziakova 2013-10-29 08:53:52 EDT
Verified for EAP 6.2.0 ER6

Note You need to log in before you can comment on or make changes to this bug.