Bug 999888 - Bad Obsoletes cause removal of fedora-release-rawhide
Bad Obsoletes cause removal of fedora-release-rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 06:27 EDT by Michael Schwendt
Modified: 2013-12-05 09:50 EST (History)
5 users (show)

See Also:
Fixed In Version: fedora-release-19-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 05:32:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-22 06:27:10 EDT
Description of problem:

Today's fedora-release wants to erase my fedora-release-rawhide package, and I would need to reinstall it:

Installing:
 fedora-release           noarch 19-3                     updates-testing  32 k
     replacing  fedora-release-rawhide.noarch 19-2

The reason is that in fedora-release.spec there is an Obsoletes tag that increases automatically with updates of the package:

  Obsoletes:      fedora-release-rawhide < %{version}-%{release}

Instead, that one should specify the fixed/hardcoded version-release of the last fedora-release-rawhide it wants to replace. According to the %changelog that would be:

  Obsoletes:      fedora-release-rawhide < 19-0.4

  https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages

Else every new update of this package would remove fedora-release-rawhide again.
Comment 1 Igor Gnatenko 2013-08-22 09:46:31 EDT
Confirm.
Comment 2 Vít Ondruch 2013-08-26 04:05:21 EDT
This surprised me today as well. Please fix this issue. Thanks.
Comment 3 Fedora Update System 2013-11-14 00:52:35 EST
fedora-release-19-5 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedora-release-19-5
Comment 4 Fedora Update System 2013-11-15 15:35:15 EST
Package fedora-release-19-5:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-release-19-5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21411/fedora-release-19-5
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-12-03 05:32:35 EST
fedora-release-19-5 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Kevin Kofler 2013-12-04 18:24:06 EST
What I don't understand is: Why the heck do we Obsolete fedora-release-rawhide at all?
1. It is disabled by default when installed.
2. It is not installed by default (hasn't been for ages), so only people who explicitly installed it have it installed.
3. Every time I upgrade to a new Fedora release, I have to reinstall fedora-release-rawhide so my repoquery --repoid=rawhide works!
What's the point? Why can't we remove that Obsoletes entirely rather than "fixing" it to be <%{fedora}-1?
Comment 7 Michael Schwendt 2013-12-05 04:39:51 EST
It is done once to take you from Rawhide to Branched.

Then, if you want to return to Rawhide or only get access to the repo again, you need to be explicit by reinstalling the package (and reenabling Rawhide if that's desired).

I think more people want to go from Fedora development to the next release, than to stay using Rawhide across multiple development cycles. Rawhide is not a real rolling-release.
Comment 8 Vít Ondruch 2013-12-05 05:03:53 EST
I installed F20 alpha and later fedora-release-rawhide package to be able to use repoquery on rawhide packages. And then suddenly the fedora-release-rawhide was removed by update of fedora-release. That does not make sense. I actually never switched between rawhide and branched, yet my fedora-release-rawhide was removed. That does not make sense.
Comment 9 Kevin Kofler 2013-12-05 05:53:46 EST
Same here, I install fedora-release-rawhide on Fedora n to be able to do repoqueries, then I upgrade to Fedora n+1, it gets removed, I readd it, it gets removed again when I upgrade to Fedora n+2 etc. This reminds me of the legend of Sisyphus and Tantalus, and really tests my nerves.

I think this Obsoletes is quite unexpected and causes more problems than it solves.
Comment 10 Michael Schwendt 2013-12-05 06:26:05 EST
Re: comment 8

_That_ is exactly why I had opened this ticket, albeit for F19. It has been fixed for F19 and F20 with a hardcoded maximum version that's low enough.


Re: comment 9

That would need a different fix, since the Obsoletes in fedora-release +1 would trigger again.
Comment 11 Kevin Kofler 2013-12-05 09:50:33 EST
That's my point. This "fix" is not sufficient. The Obsoletes should be removed entirely and in all branches.

Note You need to log in before you can comment on or make changes to this bug.