Bug 999894 - Undefined symbol from /lib64/libjavascriptcoregtk-3.0.so.0
Undefined symbol from /lib64/libjavascriptcoregtk-3.0.so.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: webkitgtk3 (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 06:44 EDT by Serge Matveenko
Modified: 2013-08-27 07:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 07:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Affected message. (808 bytes, application/zip)
2013-08-26 10:47 EDT, Serge Matveenko
no flags Details

  None (edit)
Description Serge Matveenko 2013-08-22 06:44:17 EDT
Description of problem:

Evolution crashes on reply when text selected for quoting contains new line character.

The error reported to console is "evolution: symbol lookup error: /lib64/libjavascriptcoregtk-3.0.so.0: undefined symbol: _ZN3JSC9Structure16putSpecificValueERNS_12JSGlobalDataEFS_12PropertyNamgEjPNS_6JSCellE"


Version-Release number of selected component (if applicable):

Name        : evolution
Arch        : x86_64
Version     : 3.8.5
Release     : 2.fc19


How reproducible:

Always.


Steps to Reproduce:
1. Select message with preview enabled.
2. Select multiline text in preview window.
3. Hit "reply" or "group reply" button

Actual results:

Evolution crashes with message

evolution: symbol lookup error: /lib64/libjavascriptcoregtk-3.0.so.0: undefined symbol: _ZN3JSC9Structure16putSpecificValueERNS_12JSGlobalDataEFS_12PropertyNamgEjPNS_6JSCellE


Expected results:

Reply editor window opened.
Comment 1 Milan Crha 2013-08-23 01:44:12 EDT
Thanks for a bug report. The library is part of webkitgtk3, thus I move it there. Could you write here a version of it, please? (rpm -q webkitgtk3).
Comment 2 Serge Matveenko 2013-08-23 03:55:22 EDT
$ rpm -q webkitgtk3
webkitgtk3-2.0.4-1.fc19.x86_64
Comment 3 Serge Matveenko 2013-08-23 03:57:49 EDT
I'm using evolution-ews. Dont know is it important or not.
Comment 4 Tomas Popela 2013-08-26 10:30:17 EDT
Hi, thank you for your bug report. Me and Milan can't reproduce it. It happens for you on every email?
Comment 5 Serge Matveenko 2013-08-26 10:46:11 EDT
Hi, just realized that only some of messages are affected.

Attaching one that is affected.

It is plain text message containing quoted text.

You need to select text from the "bbb..." line to the "ccc..." line.
Comment 6 Serge Matveenko 2013-08-26 10:47:05 EDT
Created attachment 790553 [details]
Affected message.
Comment 7 Milan Crha 2013-08-27 04:37:37 EDT
I've installed:
   $ rpm -q webkitgtk3
   webkitgtk3-2.0.4-1.fc19.x86_64

and I imported your message into a subfolder of On This Computer/Inbox and selected the beginning of "bbb" at the end of "ccc" with a mouse drag and it did not crash to me, neither wrote anything on a console of evolution.

Could it be that the installation/update of the webkitgtk3 failed in some weird way, left the libraries half update and half with its previous version?

   $ ls -l /lib64/libjavascriptcoregtk-*
lrwxrwxrwx. 1 root root      35 Jul  4 11:02 /lib64/libjavascriptcoregtk-1.0.so.0 -> libjavascriptcoregtk-1.0.so.0.13.14
-rwxr-xr-x. 1 root root 5730288 Jun  7 17:10 /lib64/libjavascriptcoregtk-1.0.so.0.13.14
lrwxrwxrwx. 1 root root      35 Aug 26 09:57 /lib64/libjavascriptcoregtk-3.0.so -> libjavascriptcoregtk-3.0.so.0.13.16
lrwxrwxrwx. 1 root root      35 Aug 26 09:57 /lib64/libjavascriptcoregtk-3.0.so.0 -> libjavascriptcoregtk-3.0.so.0.13.16
-rwxr-xr-x. 1 root root 5730248 Jul 22 11:02 /lib64/libjavascriptcoregtk-3.0.so.0.13.16
Comment 8 Serge Matveenko 2013-08-27 04:57:58 EDT
$ rpm -q webkitgtk3
webkitgtk3-2.0.4-1.fc19.x86_64

$ ls -l /lib64/libjavascriptcoregtk-*
lrwxrwxrwx. 1 root root      35 авг 20 16:21 /lib64/libjavascriptcoregtk-3.0.so.0 -> libjavascriptcoregtk-3.0.so.0.13.16
-rwxr-xr-x. 1 root root 5730248 июл 22 13:02 /lib64/libjavascriptcoregtk-3.0.so.0.13.16
Comment 9 Milan Crha 2013-08-27 06:52:03 EDT
Hrm, even with uninstalled webkitgtk (and gimp) and restarted evolution I do not get the crash. Could you try to:
   $ yum downgrade webkitgtk3
   $ yum update webkitgtk3

just in case the previous update failed for any reason, please?

Also, I do not expect you doing anything differently from me, but to be sure, I place mouse cursor at the beginning of the first "bbb", push down mouse left button and drag it at the end of "ccc" line, then I release the mouse button, thus there are selected all "bbb" and "ccc" with "> ccc" as well.
Comment 10 Serge Matveenko 2013-08-27 07:20:44 EDT
$ yum downgrade webkitgtk3
$ yum update webkitgtk3

fixed the problem. Odd.

Thank you very much for support and keep up the good work!

Note You need to log in before you can comment on or make changes to this bug.