Bug 999895 - Change the default homepage to "about:newtab"
Change the default homepage to "about:newtab"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 06:47 EDT by Allan Day
Modified: 2014-02-12 09:41 EST (History)
6 users (show)

See Also:
Fixed In Version: xulrunner-27.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 22:43:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Day 2013-08-22 06:47:30 EDT
When someone opens a new browser window, the best thing we can do is make it easy for them to visit a bunch of pages that they might be interested in. This is helpful behaviour, and reduces the amount of work that the user has to do. (Incidentally, it is what Google Chrome does.)

It is quite easy to get this behaviour in Firefox: you simply change the default homepace to "about:newtab".

Since this is the most helpful thing we can do for the user, it would make a great default setting.
Comment 1 Martin Stransky 2013-08-22 11:00:04 EDT
Thanks. Do you mind to create a tracking bug for this and give all those bugs as deps? Like "Firefox desktop integration" or so...
Comment 2 Jan Horak 2013-08-30 05:37:45 EDT
I understand your request but do we have any agreement on this from Fedora guys? Currently they want us to set homepage to: http://start.fedoraproject.org/
Comment 3 Martin Stransky 2013-08-30 05:45:12 EDT
Jan, the plan is to move start.fedoraproject.org to one of the tab screen. I guess the first one. I wonder if there's any option for that. We should also upstream such change - it can be interesting for other distros too.
Comment 4 Fedora Update System 2014-02-04 13:56:36 EST
xulrunner-27.0-1.fc20,firefox-27.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xulrunner-27.0-1.fc20,firefox-27.0-1.fc20
Comment 5 Fedora Update System 2014-02-04 13:57:01 EST
xulrunner-27.0-1.fc19,firefox-27.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-27.0-1.fc19,firefox-27.0-1.fc19
Comment 6 Fedora Update System 2014-02-05 22:43:15 EST
xulrunner-27.0-1.fc20, firefox-27.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 ArcFi 2014-02-10 01:15:54 EST
Is there an easy way to restore previous session?
What about default "about:home" which has "Restore previous session" button?
Comment 8 Martin Stransky 2014-02-10 03:14:45 EST
You can set your homepage at Menu, Edit -> Preferences -> General.
Comment 9 Fedora Update System 2014-02-12 09:41:57 EST
xulrunner-27.0-1.fc19, firefox-27.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.