Bug 999914 - libvirtd is not relabelling the FD from virDomainOpenGraphics
libvirtd is not relabelling the FD from virDomainOpenGraphics
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks: 999292
  Show dependency treegraph
 
Reported: 2013-08-22 07:18 EDT by Daniel Berrange
Modified: 2013-09-05 13:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 999925 (view as bug list)
Environment:
Last Closed: 2013-09-05 13:28:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2013-08-22 07:18:03 EDT
Description of problem:
When virt-viewer attempts to run virDomainOpenGraphics, strace shows sendmsg() sending the FD, but QEMU never gets it with recvmsg(). THis leads to this error


2013-08-22 10:02:48.263+0000: 11573: debug : virDomainOpenGraphics:21172 : dom=0x1283e10, (VM: name=demo, uuid=62e2a27e-2f92-5545-2c8e-38b2cec76487), idx=0, fd=15, flags=1
(virt-viewer:11573): virt-viewer-DEBUG: Error internal error: unable to execute QEMU command 'getfd': No file descriptor supplied via SCM_RIGHTS


The problem is that the FD libvirt gets is from an unconfined app. It passes this onto QEMU, which will be forbidden to access it. Libvirt needs to relabel it to the svirt image label to allow QEMU access.


Version-Release number of selected component (if applicable):
libvirt-0.10.2-22

How reproducible:
Always

Steps to Reproduce:
1. virt-viewer -c qemu:///session --debug --attach guestname
2.
3.

Actual results:
See the error message
(virt-viewer:11573): virt-viewer-DEBUG: Error internal error: unable to execute QEMU command 'getfd': No file descriptor supplied via SCM_RIGHTS

Expected results:
virDomainOpenGraphics completes without error

Additional info:
Comment 2 Daniel Berrange 2013-08-22 08:36:24 EDT
commit b6b94374b3bf6b44633ee99a68868141b6cd9ed8
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Thu Aug 22 12:38:26 2013 +0100

    Set security label on FD for virDomainOpenGraphics
Comment 4 Jiri Denemark 2013-09-05 13:28:15 EDT
As Daniel pointed out in the patch review:

Turns out the RHEL-6 QEMU lacks the monitor command to support this API,
so adding the patch to libvirt is pointless.

We can close this bug then.

Note You need to log in before you can comment on or make changes to this bug.