Bug 999918 - pki-selinux clutters install.log with /sbin/restorecon .... failed: No such file or directory
pki-selinux clutters install.log with /sbin/restorecon .... failed: No such ...
Status: CLOSED DUPLICATE of bug 998715
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pki-core (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
: Reopened
Depends On:
Blocks: 972747
  Show dependency treegraph
 
Reported: 2013-08-22 07:21 EDT by Alexander Todorov
Modified: 2013-08-29 14:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 14:03:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2013-08-22 07:21:57 EDT
Description of problem:

From install.log:


Installing pki-selinux-9.0.3-31.el6.noarch
/sbin/restorecon:  lstat(/etc/pki-ca*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/pki-kra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/pki-ocsp*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/pki-ra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/pki-tks*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/pki-tps*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/sysconfig/pki/ca*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/sysconfig/pki/kra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/sysconfig/pki/ocsp*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/sysconfig/pki/ra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/sysconfig/pki/tks*) failed:  No such file or directory
/sbin/restorecon:  lstat(/etc/sysconfig/pki/tps*) failed:  No such file or directory
/sbin/restorecon:  lstat(/opt/nfast*) failed:  No such file or directory
/sbin/restorecon:  lstat(/usr/bin/dtomcat5-pki-ca) failed:  No such file or directory
/sbin/restorecon:  lstat(/usr/bin/dtomcat5-pki-kra) failed:  No such file or directory
/sbin/restorecon:  lstat(/usr/bin/dtomcat5-pki-ocsp) failed:  No such file or directory
/sbin/restorecon:  lstat(/usr/bin/dtomcat5-pki-tks) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/lib/pki-ca*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/lib/pki-kra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/lib/pki-ocsp*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/lib/pki-ra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/lib/pki-tks*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/lib/pki-tps*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/log/pki-ca*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/log/pki-kra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/log/pki-ocsp*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/log/pki-ra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/log/pki-tks*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/log/pki-tps*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki/ca*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki-ca.pid) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki/kra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki-kra.pid) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki/ocsp*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki-ocsp.pid) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki/ra*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki/tks*) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki-tks.pid) failed:  No such file or directory
/sbin/restorecon:  lstat(/var/run/pki/tps*) failed:  No such file or directory


Too many errors, will generate support calls. Please fix.
Comment 2 Miroslav Grepl 2013-08-22 07:28:50 EDT
This is expected and this is not SELinux bug but a bug in the pki-selinux pkg where "2>/dev/null" should be used.
Comment 4 Nathan Kinder 2013-08-29 14:03:22 EDT

*** This bug has been marked as a duplicate of bug 998715 ***

Note You need to log in before you can comment on or make changes to this bug.