Bug 999929 - openstack-packstack: add the location of the packstack logs to the manual
openstack-packstack: add the location of the packstack logs to the manual
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
unspecified Severity high
: beta
: 4.0
Assigned To: Ivan Chavero
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 07:32 EDT by Yogev Rabl
Modified: 2013-12-19 19:21 EST (History)
6 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.8.dev835.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:21:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 53269 None None None Never

  None (edit)
Description Yogev Rabl 2013-08-22 07:32:11 EDT
There's no mention of the packstack logs in the documentation: 
- their location.
- how to use them (during debugging).
- write logs in debug level.
Comment 2 Ivan Chavero 2013-10-23 00:59:35 EDT
I'm adding the location of the packstack logs to the README file and how to make it write more detailed log information to te logfile.
Comment 3 Ivan Chavero 2013-10-23 01:01:44 EDT
also to the packstack.rst file
Comment 6 Nir Magnezi 2013-11-12 01:51:44 EST
Verified NVR: openstack-packstack-2013.2.1-0.9.dev840.el6ost.noarch

snippet from packstack man page:

   Log files and Debug info
       The  location  of  the log files and generated puppet manifests are in the /var/tmp/packstack directory under a directory named by the date in which packstack was run and a random string (e.g. /var/tmp/pack-
       stack/20131022-204316-Bf3Ek2). Inside, we find a manifest directory and the openstack-setup.log file; puppet manifests and a log file for each one are found inside the manifest directory.

       In case debugging info is needed while running packstack the -d switch will make it write more detailed information about the installation.

       Examples:

       If we need an allinone debug session:

       packstack -d --allinone

       If we need a answer file to tailor it and then debug:

       packstack --gen-answer-file=ans.txt packstack -d --answer-file=ans.txt
Comment 9 errata-xmlrpc 2013-12-19 19:21:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.