This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 999932 - desktop loading broken
desktop loading broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 07:39 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 04:27:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2013-08-22 07:39:41 EDT
Version-Release number of selected component (if applicable):
emacs-24.3-11.fc19.x86_64

How reproducible:
deterministic

Steps to Reproduce:
1. create a new directory, cd into it
2. emacs
3. edit a new file with a few lines, save it under the dir, stay in the file's buffer
4. M-x desktop-save, choose the created dir
5. C-x C-c
6. stay in the created dir
7. emacs

Actual results:
*scratch* buffer opens, there's no buffer created with the new files

Expected results:
http://www.gnu.org/software/emacs/manual/html_mono/emacs.html#Saving-Emacs-Sessions


Additional info:
Worked in early F19.
Comment 1 Petr Hracek 2013-09-23 10:28:42 EDT
Hi,

the problem was posted into emacs upstream discussion
https://groups.google.com/forum/#!topic/gnu.emacs.bug/iYbniSWmhJU
Comment 2 Ales Kozumplik 2013-09-27 04:18:21 EDT
Petr, thanks for posting that link. I even found that this has really been documented in the release NEWS:

/usr/share/emacs/24.3/etc/NEWS

** `desktop-path' no longer includes the "." directory.
Desktop files are now located in ~/.emacs.d by default.

It unfortunately looks like emacs upstream is not much afraid of breaking tiny things like this and we'll have to read the NEWS more often.

Here's what fixed it for me in my .emacs:

(setq desktop-path (cons "./" desktop-path))

As far as I'm concerned you can close this now as NOTABUG.
Comment 3 Petr Hracek 2013-09-27 04:27:17 EDT
Hello Ales,

thanks for your update as well.
I will mark notice about this problem in case that other BZs will come up.

Note You need to log in before you can comment on or make changes to this bug.