Bug 999939 - Dist-geo-rep : geo-rep syncs block special, character special files and pipe as regular files to the slave
Dist-geo-rep : geo-rep syncs block special, character special files and pipe...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Amar Tumballi
Vijaykumar Koppad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 07:56 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.24rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-08-22 07:56:53 EDT
Description of problem:Geo-rep syncs block special, character special and pipe as regular file to the slave 


Version-Release number of selected component (if applicable):glusterfs-3.4.0.21rhs-1.el6rhs.x86_64


How reproducible:Happens everytime 


Steps to Reproduce:
1.create and start a geo-rep relationship between master and slave. 
2.on the master create block special , character special files and pipe like mknod file_block b 12 5, mknod file_char c 12 5, and mknod file_pipe pipe
3.check it on the slave. 

Actual results:geo-rep syncs them as regular files


Expected results: Either it should be synced as the same file type or not sync at all 


Additional info:
Comment 2 Amar Tumballi 2013-08-27 02:14:16 EDT
https://code.engineering.redhat.com/gerrit/#/c/11998
Comment 3 Vijaykumar Koppad 2013-08-28 06:36:31 EDT
verified on glusterfs-3.4.0.24rhs-1.el6rhs.x86_64
Comment 4 Scott Haines 2013-09-23 18:38:52 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:31 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.