Bug 999946 - Camel FTPS binding cannot be used because of java.lang.NoClassDefFoundError: javax/net/ssl/SSLException
Camel FTPS binding cannot be used because of java.lang.NoClassDefFoundError: ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER8
: 6.0.0
Assigned To: David Ward
Jiri Sedlacek
:
Depends On: 1038622 1044500
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 08:17 EDT by Jiri Sedlacek
Modified: 2015-08-02 19:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ftps switchyard.xml (1.35 KB, text/xml)
2013-09-30 04:13 EDT, Jiri Sedlacek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1819 Major Closed Camel FTPS binding cannot be used because of java.lang.NoClassDefFoundError: javax/net/ssl/SSLException 2015-11-09 03:56 EST

  None (edit)
Description Jiri Sedlacek 2013-08-22 08:17:04 EDT
I configured Camel binding for switchyard service for ftps, exception below is thrown, class javax.net.ssl.SSLException is not on the classpath.

The root cause of the problem is probably different, but it's not shown.

Caused by: java.lang.NoClassDefFoundError: javax/net/ssl/SSLException
	at org.apache.camel.component.file.remote.FtpsEndpoint.createRemoteFileOperations(FtpsEndpoint.java:188)
	at org.apache.camel.component.file.remote.FtpEndpoint.buildConsumer(FtpEndpoint.java:60)
	at org.apache.camel.component.file.remote.RemoteFileEndpoint.createConsumer(RemoteFileEndpoint.java:87)
	at org.apache.camel.component.file.remote.RemoteFileEndpoint.createConsumer(RemoteFileEndpoint.java:34)
	at org.apache.camel.impl.EventDrivenConsumerRoute.addServices(EventDrivenConsumerRoute.java:65)
	at org.apache.camel.impl.DefaultRoute.onStartingServices(DefaultRoute.java:80)
	at org.apache.camel.impl.RouteService.warmUp(RouteService.java:133)
	at org.apache.camel.impl.DefaultCamelContext.doWarmUpRoutes(DefaultCamelContext.java:2000)
	at org.apache.camel.impl.DefaultCamelContext.safelyStartRouteServices(DefaultCamelContext.java:1928)
	at org.apache.camel.impl.DefaultCamelContext.safelyStartRouteServices(DefaultCamelContext.java:1950)
	at org.apache.camel.impl.DefaultCamelContext.startRouteService(DefaultCamelContext.java:1827)
	at org.apache.camel.impl.DefaultCamelContext.startRoute(DefaultCamelContext.java:733)
	at org.apache.camel.impl.DefaultCamelContext.startRouteDefinitions(DefaultCamelContext.java:1803)
	at org.apache.camel.impl.DefaultCamelContext.addRouteDefinitions(DefaultCamelContext.java:675)
	at org.apache.camel.impl.DefaultCamelContext.addRouteDefinition(DefaultCamelContext.java:680)
	at org.switchyard.component.camel.common.handler.InboundHandler.<init>(InboundHandler.java:67)
	at org.switchyard.component.camel.common.deploy.BaseBindingActivator.createInboundHandler(BaseBindingActivator.java:51)
	at org.switchyard.component.camel.common.deploy.BaseBindingActivator.activateBinding(BaseBindingActivator.java:43)
	at org.switchyard.deploy.internal.Deployment.deployServiceBindings(Deployment.java:607)
	at org.switchyard.deploy.internal.Deployment.start(Deployment.java:143)
	at org.switchyard.as7.extension.deployment.SwitchYardDeployment.start(SwitchYardDeployment.java:101)
	at org.switchyard.as7.extension.services.SwitchYardService.start(SwitchYardService.java:73)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	... 3 more
Caused by: java.lang.ClassNotFoundException: javax.net.ssl.SSLException from [Module "org.apache.camel.ftp:main" from local module loader @20e8ac93 (finder: local module finder @b99f7c6 (roots: /home/jsedlace/soa6/servers/ER1/jboss-eap-6.1/modules,/home/jsedlace/soa6/servers/ER1/jboss-eap-6.1/modules/system/layers/soa,/home/jsedlace/soa6/servers/ER1/jboss-eap-6.1/modules/system/layers/base))]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:196) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119) [jboss-modules.jar:1.2.0.Final-redhat-1]
	... 27 more
Comment 1 David Ward 2013-09-09 09:54:15 EDT
Can you please attach your test case? Thank you!
Comment 2 Jiri Sedlacek 2013-09-30 04:13:28 EDT
Created attachment 804975 [details]
ftps switchyard.xml

David, sorry for the big delay, I lost the message in thousands of others from bugzilla :(

I've attached switchyard.xml from quickstart camel-ftp-binding, just modified for ftps, same exception as I wrote earlier should be thrown.
Comment 3 Jochen Cordes 2013-10-30 18:14:44 EDT
I have solved this issue by adding <module name="javax.api"/> under <dependencies> in JBOSS_HOME/modules/system/layers/soa/org/apache/camel/ftp/main/module.xml.
Comment 4 JBoss JIRA Server 2013-11-07 08:05:34 EST
David Ward <dward@jboss.org> made a comment on jira SWITCHYARD-1819

https://github.com/jboss-switchyard/release/pull/313

Recreated, fixed, tested successfully.
Comment 5 JBoss JIRA Server 2013-11-11 20:41:03 EST
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1819

pushed
Comment 6 Jiri Sedlacek 2013-12-18 08:17:18 EST
cannot be verified now because of bug #1044500
Comment 7 Keith Babo 2013-12-18 08:53:01 EST
BZ 1044500 should be fixed in ER8 as I'm pretty sure it's an issue with drools/jbpm modularization.  See my comment in that BZ for details.  I would retest this issue with ER8 as well.
Comment 8 Jiri Sedlacek 2014-01-07 05:56:25 EST
verified in ER8
Comment 9 JBoss JIRA Server 2014-06-16 19:53:46 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1819 to Closed

Note You need to log in before you can comment on or make changes to this bug.