Bug 999947 - [RFE] Refresh Network configuration periodically
[RFE] Refresh Network configuration periodically
Status: CLOSED DUPLICATE of bug 1240719
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: Scott Herold
Meni Yakove
network
: FutureFeature
Depends On:
Blocks: 988469 1058499
  Show dependency treegraph
 
Reported: 2013-08-22 08:18 EDT by Moti Asayag
Modified: 2016-01-27 04:31 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 04:29:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑future?
rule-engine: planning_ack?
danken: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Moti Asayag 2013-08-22 08:18:37 EDT
Description of problem:
Network changes manually applied on the host are not reflected to the engine unless the host is being manually refreshed using the refresh capabilities. This might lead to lack of synchronization between the current host configuration as recently collected to the current configuration on the host (e.g. manual changes performed on the host not via the setupNetworks api).
Comment 1 Moti Asayag 2013-08-25 17:41:04 EDT
Another motivation of having a monitor for refreshing the network configuration is the race between the network information collection to the IP address which is being obtained from the DHCP server:

It is not rare to see setupNetworks configures an interface for DHCP, and the immediate getVdsCaps which follows doesn't report any IP address for that interface due to latency of the DHCP server.

Having the monitor to auto-refresh such configuration will simplify the fix of bug 955429, prevent run a VM if the display network has no IP address.
Comment 3 Moti Asayag 2014-04-30 17:06:21 EDT
*** Bug 1093046 has been marked as a duplicate of this bug. ***
Comment 5 Yaniv Lavi (Dary) 2015-04-05 12:01:03 EDT
Is this similar to bz #1037612?
Comment 6 Lior Vernia 2015-04-06 03:34:57 EDT
No.
Comment 7 Yaniv Lavi (Dary) 2016-01-27 04:29:53 EST

*** This bug has been marked as a duplicate of bug 1240719 ***

Note You need to log in before you can comment on or make changes to this bug.