Bug 999969 - [RFE] Ability to create a VM with multiple NICs in a predictable order
[RFE] Ability to create a VM with multiple NICs in a predictable order
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity unspecified
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Yevgeny Zaspitsky
Meni Yakove
: AutomationBlocker, FutureFeature, Improvement
: 1076007 1157151 (view as bug list)
Depends On:
Blocks: 1094012 1157151 1195039
  Show dependency treegraph
 
Reported: 2013-08-22 09:18 EDT by Moti Asayag
Modified: 2016-03-09 15:32 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 15:32:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nyechiel: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 42636 None ABANDONED engine: add VmManagementParametersBase.updatedNetworkInterfaces Never
oVirt gerrit 42637 None ABANDONED webadmin: extract UpdateNicsParametersFactory from UI Never
oVirt gerrit 42638 None ABANDONED engine: extract ReorderVmNicsCommand logic into the util class Never
oVirt gerrit 42896 None ABANDONED restapi: use vm.nics for AddVm command Never
oVirt gerrit 43250 None None None Never

  None (edit)
Description Moti Asayag 2013-08-22 09:18:40 EDT
Description of problem:
Currently, the AddVm command creates a Vm without any interfaces.
AddVmFromTemplate creates the Vm with the exact interfaces as exist on the template. However, if the vnic profiles/networks are no longer exist, the nic will be created not attached to any network and a UpdateVmInterface command should be follow to adjust the vnic to the required one.
This can be avoided by allowing the AddVm and AddVmFromTemplate to provide a list of interfaces that the VM should be created with.

The can-do-action of the AddVm/AddVmFromTemplate should validate the correctness of the nics.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Moti Asayag 2014-03-16 08:16:31 EDT
*** Bug 1076007 has been marked as a duplicate of this bug. ***
Comment 3 Meni Yakove 2014-03-16 09:50:51 EDT
This is needed in order to run automation for Predictable_vNIC_Order.
http://liver.englab.brq.redhat.com/redirect/?url=http://wiki.ovirt.org/Feature/Predictable_vNIC_Order
Comment 4 Moti Asayag 2014-08-31 03:08:51 EDT
Another use-case for this RFE was brought up by ovirt-foreman integration:

http://projects.theforeman.org/issues/7244#note-6
Comment 5 Lior Vernia 2014-11-06 05:15:21 EST
*** Bug 1157151 has been marked as a duplicate of this bug. ***
Comment 8 Yevgeny Zaspitsky 2015-07-07 11:20:16 EDT
The RFE is intended to provide a REST-API user a way to create a VM with predictable vNIC order. The ${header} is one of the available solutions for the problem. However REST-API maintainers are against this approach, so the implemented solution is to allow the REST-API user to invoke "reordermacaddresses" action explicitly.

URL: /vms/{vm:id}/reordermacaddresses
Comment 9 Dan Kenigsberg 2015-08-16 07:08:54 EDT
Patch https://gerrit.ovirt.org/#/c/43250/ is already merged in 3.6, and ready for verification.
Comment 11 Michael Burman 2015-11-18 08:55:41 EST
Verified on - 3.6.0.3-0.1.el6

Yaniv, Yevgeny according to comment 8 above ^^ the summary of this RFE should be changed(origin summary not relevant). Please change it accordingly, thanks.
Comment 12 Yevgeny Zaspitsky 2015-11-18 09:12:55 EST
AFAIK either Bugzilla doesn't allow updating a submitted description/comment or I do nt have permission to do that.
Comment 14 errata-xmlrpc 2016-03-09 15:32:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.