Bug 999997 - NM ignores the profile's channel setting and connects to wifi network
NM ignores the profile's channel setting and connects to wifi network
Status: CLOSED DUPLICATE of bug 1000096
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Williams
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 09:50 EDT by Vitezslav Humpa
Modified: 2013-08-31 10:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 10:06:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2013-08-22 09:50:39 EDT
Description of problem:
In nmcli, setting the 802-11-wireless.channel property to a specific channel should result for the profile to only connect to networks on the channel specified. However, currently this setting is ignored and profile is used to successfully connect to a same SSID wifi network on different channel as well.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.9.0-9.git20130807.el7.x86_64

Steps to Reproduce:
1. nmcli connection add type wifi ifname yyy con-name xxx autoconnect off ssid xxx
2. nmcli connection edit xxx
3. nmcli> set 802-11-wireless.band bg
4. nmcli> set 802-11-wireless.channel 11 #(any other than the network is on)
5. Save and quit, nmcli connection up xxx

Actual results:
Profile connects normally

Expected results:
It does not, as the network does not fit the profile
Comment 1 Dan Williams 2013-08-31 10:06:56 EDT
At the moment, NM doesn't allow locking the channel or band of an access point due to kernel/driver and supplicant restrictions, except for AdHoc and Hotspot connections where the channel is determined by the local machine.  These parameters should be hidden from nmcli when the wifi mode is "infrastructure".  I'm going to dupe this bug to 1000096 since the problem is actually the same.

*** This bug has been marked as a duplicate of bug 1000096 ***

Note You need to log in before you can comment on or make changes to this bug.