Bug 1599815 (CVE-2018-10891) - CVE-2018-10891 moodle: Quiz question bank import preview could execute JavaScript
Summary: CVE-2018-10891 moodle: Quiz question bank import preview could execute JavaSc...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2018-10891
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1599816 1599817
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-10 15:56 UTC by Laura Pardo
Modified: 2019-09-29 14:43 UTC (History)
2 users (show)

Fixed In Version: moodle 3.5.1, moodle 3.4.4, moodle 3.3.7, moodle 3.1.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:32:17 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-07-10 15:56:13 UTC
A flaw was found in Moodle. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.


References:
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62820

Comment 1 Laura Pardo 2018-07-10 15:56:38 UTC
Created moodle tracking bugs for this issue:

Affects: epel-7 [bug 1599817]
Affects: fedora-all [bug 1599816]

Comment 2 Product Security DevOps Team 2019-06-10 10:32:17 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.