Bug 1607323 (CVE-2018-14340) - CVE-2018-14340 wireshark: Multiple dissectors could crash (wnpa-sec-2018-36)
Summary: CVE-2018-14340 wireshark: Multiple dissectors could crash (wnpa-sec-2018-36)
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-14340
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1607333 1607334 1612146
Blocks: 1607335
TreeView+ depends on / blocked
 
Reported: 2018-07-23 09:48 UTC by Andrej Nemec
Modified: 2021-02-16 23:55 UTC (History)
7 users (show)

Fixed In Version: wireshark 2.6.2, wireshark 2.4.8, wireshark 2.2.16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-31 22:32:52 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:1047 0 None None None 2020-03-31 19:15:58 UTC

Description Andrej Nemec 2018-07-23 09:48:58 UTC
It was found that dissectors that support zlib decompression could crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Upstream bug(s):

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14675

External References:

https://www.wireshark.org/security/wnpa-sec-2018-36.html

Comment 1 Andrej Nemec 2018-07-23 09:58:59 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1607334]

Comment 5 Pedro Yóssis Silva Barbosa 2018-08-06 19:41:57 UTC
Upstream patch:

https://code.wireshark.org/review/#/c/27561/2/epan/tvbuff_zlib.c

Comment 6 errata-xmlrpc 2020-03-31 19:15:56 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2020:1047 https://access.redhat.com/errata/RHSA-2020:1047

Comment 7 Product Security DevOps Team 2020-03-31 22:32:52 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-14340


Note You need to log in before you can comment on or make changes to this bug.