Bug 1607321 (CVE-2018-14342) - CVE-2018-14342 wireshark: BGP dissector large loop (wnpa-sec-2018-34)
Summary: CVE-2018-14342 wireshark: BGP dissector large loop (wnpa-sec-2018-34)
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-14342
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20180718,repor...
Depends On: 1607333 1607334
Blocks: 1607335
TreeView+ depends on / blocked
 
Reported: 2018-07-23 09:45 UTC by Andrej Nemec
Modified: 2019-06-14 08:56 UTC (History)
7 users (show)

Fixed In Version: wireshark 2.6.2, wireshark 2.4.8, wireshark 2.2.16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-02 19:19:39 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2018-07-23 09:45:33 UTC
It was reported that Wireshark's BGP dissector could loop infinitely. It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Upstream bug(s):

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13741

External References:

https://www.wireshark.org/security/wnpa-sec-2018-34.html

Comment 1 Andrej Nemec 2018-07-23 09:56:57 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1607334]

Comment 5 Pedro Yóssis Silva Barbosa 2018-08-02 19:22:19 UTC
Statement:

This issue did not affect the versions of wireshark as shipped with Red Hat Enterprise Linux 6 and 7 (versions 1.8.10 and 1.10.14, respectively).


Note You need to log in before you can comment on or make changes to this bug.