Bug 1607324 (CVE-2018-14343) - CVE-2018-14343 wireshark: ASN.1 BER and related dissectors crash (wnpa-sec-2018-37)
Summary: CVE-2018-14343 wireshark: ASN.1 BER and related dissectors crash (wnpa-sec-20...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-14343
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1607333 1607334
Blocks: 1607335
TreeView+ depends on / blocked
 
Reported: 2018-07-23 09:49 UTC by Andrej Nemec
Modified: 2019-09-29 14:45 UTC (History)
6 users (show)

Fixed In Version: wireshark 2.6.2, wireshark 2.4.8, wireshark 2.2.16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-03 19:28:34 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2018-07-23 09:49:53 UTC
It was found that ASN.1 BER dissector could crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Upstream bug(s):

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14682

External References:

https://www.wireshark.org/security/wnpa-sec-2018-37.html

Comment 1 Andrej Nemec 2018-07-23 09:56:41 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 1607334]

Comment 3 Pedro Yóssis Silva Barbosa 2018-08-03 19:28:46 UTC
Statement:

This issue did not affect the versions of wireshark as shipped with Red Hat Enterprise Linux 6 and 7 (versions 1.8.10 and 1.10.14, respectively).


Note You need to log in before you can comment on or make changes to this bug.