Bug 1546226 (CVE-2018-7053) - CVE-2018-7053 irssi: use-after-free when SASL messages are received in unexpected order
Summary: CVE-2018-7053 irssi: use-after-free when SASL messages are received in unexpe...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-7053
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1546227 1562357
Blocks: 1546283
TreeView+ depends on / blocked
 
Reported: 2018-02-16 16:45 UTC by Laura Pardo
Modified: 2019-09-29 14:32 UTC (History)
4 users (show)

Fixed In Version: irssi 1.0.7, irssi 1.1.1
Doc Type: If docs needed, set a value
Doc Text:
A use-after-free was found in the way Irssi, version 0.8.18 and later, handled out of order SASL messages sent by an IRC server. A remote attacker, who controls an IRC server, could crash the application by exploiting this flaw.
Clone Of:
Environment:
Last Closed: 2018-03-30 10:46:02 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-02-16 16:45:01 UTC
A use-after-free was discovered in Irssi 0.8.18 and later when SASL messages
from a server are received in unexpected order. A remote attacker, in control of
an IRC server, could cause a crash in Irssi clients by leveraging this flaw.

Upstream commit:
https://github.com/irssi/irssi/commit/b8d3301d34f383f039071214872570385de1bb59

Upstream patch:
https://github.com/irssi/irssi/commit/36564717c9f701e3a339da362ab46d220d27e0c1

References:
https://irssi.org/security/irssi_sa_2018_02.txt

Comment 1 Laura Pardo 2018-02-16 16:45:32 UTC
Created irssi tracking bugs for this issue:

Affects: fedora-all [bug 1546227]

Comment 4 Riccardo Schirone 2018-03-30 10:45:22 UTC
Statement:

This issue did not affect the versions of Irssi as shipped with Red Hat Enterprise Linux 6 and 7 as they did not include support for SASL.


Note You need to log in before you can comment on or make changes to this bug.