Bug 1695679 (CVE-2019-5953) - CVE-2019-5953 wget: do_conversion() heap-based buffer overflow vulnerability
Summary: CVE-2019-5953 wget: do_conversion() heap-based buffer overflow vulnerability
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-5953
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1696733 1696734 1696735 1696736 1696738 1733631 1733632
Blocks: 1695681
TreeView+ depends on / blocked
 
Reported: 2019-04-03 15:20 UTC by Pedro Sampaio
Modified: 2019-10-22 11:09 UTC (History)
3 users (show)

Fixed In Version: wget 1.20.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 16:13:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:0983 None None None 2019-05-07 04:20:19 UTC
Red Hat Product Errata RHSA-2019:1228 None None None 2019-05-14 15:15:50 UTC
Red Hat Product Errata RHSA-2019:2979 None None None 2019-10-08 10:00:41 UTC
Red Hat Product Errata RHSA-2019:3168 None None None 2019-10-22 11:09:18 UTC

Description Pedro Sampaio 2019-04-03 15:20:02 UTC
A buffer overflow vulnerability was found in GNU Wget 1.20.1 and earlier. An attacker may be able to cause a denial-of-service (DoS) or may execute an arbitrary code.

References:

https://jvn.jp/en/jp/JVN25261088/

Comment 3 Stefan Cornelius 2019-04-05 14:25:08 UTC
Statement:

This issue did not affect the versions of wget as shipped with Red Hat Enterprise Linux 5 and 6.

This issue affects the versions of wget as shipped with Red Hat Enterprise Linux 7.

Comment 4 Stefan Cornelius 2019-04-05 14:25:45 UTC
Created wget tracking bugs for this issue:

Affects: fedora-all [bug 1696738]

Comment 6 Marian Rehak 2019-04-09 06:57:23 UTC
The new buffer overflow bug fixed upstream in versions 1.20.2 and 1.20.3
http://lists.gnu.org/archive/html/bug-wget/2019-04/msg00001.html
http://lists.gnu.org/archive/html/bug-wget/2019-04/msg00015.html

Comment 8 Stefan Cornelius 2019-04-25 13:11:11 UTC
The vulnerability is a heap-based buffer overflow within the "do_conversion()" function in src/iri.c when processing Internationalized Resource Identifiers. An attacker can exploit this vulnerability to cause a crash and, potentially, execute arbitrary code by, for example, tricking a user into recursively downloading a specially crafted website.

Upstream announced a fix for this issue as part of version 1.20.2. However, this version did not actually contain the necessary code changes, thus leaving version 1.20.2 vulnerable. Version 1.20.3 fixed this.

Comment 9 errata-xmlrpc 2019-05-07 04:20:18 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2019:0983 https://access.redhat.com/errata/RHSA-2019:0983

Comment 10 errata-xmlrpc 2019-05-14 15:15:49 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2019:1228 https://access.redhat.com/errata/RHSA-2019:1228

Comment 12 errata-xmlrpc 2019-10-08 10:00:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7.5 Extended Update Support

Via RHSA-2019:2979 https://access.redhat.com/errata/RHSA-2019:2979

Comment 13 errata-xmlrpc 2019-10-22 11:09:15 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7.4 Advanced Update Support
  Red Hat Enterprise Linux 7.4 Update Services for SAP Solutions
  Red Hat Enterprise Linux 7.4 Telco Extended Update Support

Via RHSA-2019:3168 https://access.redhat.com/errata/RHSA-2019:3168


Note You need to log in before you can comment on or make changes to this bug.