Bug 139648

Summary: IPW2100 firmware can't loaded if not unload udev module
Product: Red Hat Enterprise Linux 4 Reporter: Crystal Xiong <crystal.xiong>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: f.ouellet
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: RHEL40-Pre-RC2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-27 10:18:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Crystal Xiong 2004-11-17 06:31:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; (R1 
1.5); .NET CLR 1.1.4322)

Description of problem:
Can't load ipw2100-1.3 firmware if not unload udev module.

Version-Release number of selected component (if applicable):
udev-039-6.el4.2

How reproducible:
Always

Steps to Reproduce:
1. Put ipw2100-1.3 firware to /lib/firmware
2. load ipw2100 driver
   modprobe ipw2100
   Failed with firmware can't be found.
3. remove udev module
   modprobe -r udevd
4. load ipw2100 driver again
   modprobe -r ipw2100; modprobe ipw2100
   The driver can be loaded correctly.

    

Actual Results:  Only unload udev module, ipw2100 firmware can be 
loaded.

Expected Results:  udev should not affect the ipw firmware loading. 

Additional info:

Comment 1 Harald Hoyer 2004-11-17 10:49:06 UTC
there is no udevd module.. udevd is a normal process and if you kill
it, you change nothing...

you may try to upgrade udev to the FC3-updates version, which will
also be in RHEL4.

Comment 2 Crystal Xiong 2004-11-18 02:50:00 UTC
I did unload udev module, sorry for mistype to udevd. 

As I know udev-040 may fix this problem. 






Comment 3 Harald Hoyer 2004-11-18 10:48:12 UTC
there is no udev module also

Comment 4 Crystal Xiong 2004-11-19 03:19:46 UTC
SOrry, recheck it. It is udevd daemon. After killed the daemon, 
hotplug can load the firmware correclty. 

Comment 5 Dave Jones 2004-11-27 06:06:46 UTC
*** Bug 139466 has been marked as a duplicate of this bug. ***

Comment 6 Harald Hoyer 2004-11-29 11:10:46 UTC
are you sure you have to kill the udevd daemon??

Try to just reload the module

# modprobe ipw2100
   Failed with firmware can't be found.
# modprobe -r ipw2100; modprobe ipw2100

Comment 7 Crystal Xiong 2004-12-27 10:18:00 UTC
Did this test again on RHEL40-Pre-RC2. Now the 1.0.0 2100 driver can 
load firmware successfully without needing to unload udev module.
So this bug seems to have been fixed.


Comment 8 Harald Hoyer 2004-12-28 13:44:56 UTC
there is no udev module...