Bug 139648 - IPW2100 firmware can't loaded if not unload udev module
IPW2100 firmware can't loaded if not unload udev module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 139466 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 01:31 EST by Crystal Xiong
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL40-Pre-RC2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-27 05:18:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Crystal Xiong 2004-11-17 01:31:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; (R1 
1.5); .NET CLR 1.1.4322)

Description of problem:
Can't load ipw2100-1.3 firmware if not unload udev module.

Version-Release number of selected component (if applicable):
udev-039-6.el4.2

How reproducible:
Always

Steps to Reproduce:
1. Put ipw2100-1.3 firware to /lib/firmware
2. load ipw2100 driver
   modprobe ipw2100
   Failed with firmware can't be found.
3. remove udev module
   modprobe -r udevd
4. load ipw2100 driver again
   modprobe -r ipw2100; modprobe ipw2100
   The driver can be loaded correctly.

    

Actual Results:  Only unload udev module, ipw2100 firmware can be 
loaded.

Expected Results:  udev should not affect the ipw firmware loading. 

Additional info:
Comment 1 Harald Hoyer 2004-11-17 05:49:06 EST
there is no udevd module.. udevd is a normal process and if you kill
it, you change nothing...

you may try to upgrade udev to the FC3-updates version, which will
also be in RHEL4.
Comment 2 Crystal Xiong 2004-11-17 21:50:00 EST
I did unload udev module, sorry for mistype to udevd. 

As I know udev-040 may fix this problem. 




Comment 3 Harald Hoyer 2004-11-18 05:48:12 EST
there is no udev module also
Comment 4 Crystal Xiong 2004-11-18 22:19:46 EST
SOrry, recheck it. It is udevd daemon. After killed the daemon, 
hotplug can load the firmware correclty. 
Comment 5 Dave Jones 2004-11-27 01:06:46 EST
*** Bug 139466 has been marked as a duplicate of this bug. ***
Comment 6 Harald Hoyer 2004-11-29 06:10:46 EST
are you sure you have to kill the udevd daemon??

Try to just reload the module

# modprobe ipw2100
   Failed with firmware can't be found.
# modprobe -r ipw2100; modprobe ipw2100
Comment 7 Crystal Xiong 2004-12-27 05:18:00 EST
Did this test again on RHEL40-Pre-RC2. Now the 1.0.0 2100 driver can 
load firmware successfully without needing to unload udev module.
So this bug seems to have been fixed.
Comment 8 Harald Hoyer 2004-12-28 08:44:56 EST
there is no udev module...

Note You need to log in before you can comment on or make changes to this bug.