Bug 19100

Summary: !(5.6.0>=5.00503) == true?
Product: [Retired] Red Hat Linux Reporter: Michael Schwendt <bugs.michael>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-10-14 07:41:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michael Schwendt 2000-10-14 07:41:05 UTC
$ rpm -q perl
  perl-5.6.0-9

A package built with

  Requires: perl >= 5.00503

in the spec file fails to install:

  error: failed dependencies:
          perl >= 5.00503 is needed by perl-MailTools-1.13-3

The same package built with:

  Requires: perl >= 5.005

installs fine. This strange behaviour is new with RPM 4.0. Why is it like
that?

Comment 1 Jeff Johnson 2000-10-15 22:57:18 UTC
The behavior is new with the introduction of an epoch in the perl-5.6.0 package
and has
little to do with rpm-4.0.

The recommended solution is to write the dependency with an explicit epoch
	Requires:  perl >= 0:5.00503




Comment 2 Pekka Savola 2000-12-17 11:49:09 UTC
*** Bug 22377 has been marked as a duplicate of this bug. ***