Bug 19100 - !(5.6.0>=5.00503) == true?
!(5.6.0>=5.00503) == true?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 22377 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-14 03:41 EDT by Michael Schwendt
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-14 03:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2000-10-14 03:41:05 EDT
$ rpm -q perl
  perl-5.6.0-9

A package built with

  Requires: perl >= 5.00503

in the spec file fails to install:

  error: failed dependencies:
          perl >= 5.00503 is needed by perl-MailTools-1.13-3

The same package built with:

  Requires: perl >= 5.005

installs fine. This strange behaviour is new with RPM 4.0. Why is it like
that?
Comment 1 Jeff Johnson 2000-10-15 18:57:18 EDT
The behavior is new with the introduction of an epoch in the perl-5.6.0 package
and has
little to do with rpm-4.0.

The recommended solution is to write the dependency with an explicit epoch
	Requires:  perl >= 0:5.00503


Comment 2 Pekka Savola 2000-12-17 06:49:09 EST
*** Bug 22377 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.