Red Hat Bugzilla – Bug 22377
Perl RPM breaks other RPMs
Last modified: 2007-04-18 12:30:13 EDT
For some odd reason RPM refuses to install modules built with the
following requires line:
Requires: perl >= 5.00503
When attempting to install an RPM with this requirement, I get the
error: failed dependencies:
perl >= 5.00503 is needed by <package>
However, output of 'rpm -q --provides perl' says:
perl <= 5.6.0
So, what's the problem here? Is the perl package to blame, or perhaps RPM
itself? We're running rpm-4.0-4 on this box.
This is an RPM fault. It thinks 5.00503 is more recent than 5.6.0 (e.g. I've had an installed
5.6.0-1 being "upgraded" to 5.00503..).
This could be worked around by specifying the epoch explicitly, like:
Requires: perl >= 1:5.6
This is a duplicate of #19100.
*** This bug has been marked as a duplicate of 19100 ***