Bug 22377 - Perl RPM breaks other RPMs
Summary: Perl RPM breaks other RPMs
Status: CLOSED DUPLICATE of bug 19100
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 13520
TreeView+ depends on / blocked
 
Reported: 2000-12-16 01:36 UTC by Michael S. Fischer
Modified: 2018-08-09 13:30 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2000-12-17 11:34:19 UTC


Attachments (Terms of Use)

Description Michael S. Fischer 2000-12-16 01:36:10 UTC
For some odd reason RPM refuses to install modules built with the 
following requires line:

Requires: perl >= 5.00503

When attempting to install an RPM with this requirement, I get the 
following error:

error: failed dependencies:
	perl >= 5.00503 is needed by <package>

However, output of 'rpm -q --provides perl' says:

perl <= 5.6.0
...

So, what's the problem here?  Is the perl package to blame, or perhaps RPM 
itself?  We're running rpm-4.0-4 on this box.

Comment 1 Pekka Savola 2000-12-17 01:22:12 UTC
This is an RPM fault.  It thinks 5.00503 is more recent than 5.6.0 (e.g. I've had an installed 
5.6.0-1 being "upgraded" to 5.00503..).

This could be worked around by specifying the epoch explicitly, like:

 Requires: perl >= 1:5.6


Comment 2 Michael Schwendt 2000-12-17 11:34:16 UTC
This is a duplicate of #19100.


Comment 3 Pekka Savola 2000-12-17 11:49:12 UTC

*** This bug has been marked as a duplicate of 19100 ***

Comment 4 openshift-github-bot 2018-08-09 13:30:07 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/f204138894d82e62ffeb1257bedeadbbbc388b44
SDN check: Fix parsing time stamp's time zone

Before this commit, if the control machine and the target machine were in
different time zones and the target machine's time zone were neither UTC
nor GMT, the SDN check would raise a ValueError exception when parsing a
systemd unit's ExecMainStartTimestamp property:

    ValueError: time data 'Tue 2018-08-07 23:09:46 EDT' does not match format '%a %Y-%m-%d %H:%M:%S %Z'

The problem is that Python's strptime cannot reliably parse time zones:
https://bugs.python.org/issue22377

The solution is to drop the time zone prior to parsing the time stamp.

This commit fixes bug 1613752.

https://bugzilla.redhat.com/show_bug.cgi?id=1613752

* roles/openshift_health_checker/openshift_checks/sdn.py
(SDNCheck.save_service_logs): Omit time zone before parsing time stamp.


Note You need to log in before you can comment on or make changes to this bug.