Bug 22377 - Perl RPM breaks other RPMs
Perl RPM breaks other RPMs
Status: CLOSED DUPLICATE of bug 19100
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
Depends On:
Blocks: 13520
  Show dependency treegraph
Reported: 2000-12-15 20:36 EST by Michael S. Fischer
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-17 06:34:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael S. Fischer 2000-12-15 20:36:10 EST
For some odd reason RPM refuses to install modules built with the 
following requires line:

Requires: perl >= 5.00503

When attempting to install an RPM with this requirement, I get the 
following error:

error: failed dependencies:
	perl >= 5.00503 is needed by <package>

However, output of 'rpm -q --provides perl' says:

perl <= 5.6.0

So, what's the problem here?  Is the perl package to blame, or perhaps RPM 
itself?  We're running rpm-4.0-4 on this box.
Comment 1 Pekka Savola 2000-12-16 20:22:12 EST
This is an RPM fault.  It thinks 5.00503 is more recent than 5.6.0 (e.g. I've had an installed 
5.6.0-1 being "upgraded" to 5.00503..).

This could be worked around by specifying the epoch explicitly, like:

 Requires: perl >= 1:5.6
Comment 2 Michael Schwendt 2000-12-17 06:34:16 EST
This is a duplicate of #19100.
Comment 3 Pekka Savola 2000-12-17 06:49:12 EST

*** This bug has been marked as a duplicate of 19100 ***

Note You need to log in before you can comment on or make changes to this bug.