Bug 100545

Summary: Installation hangs when booting from a firewire cdrom.
Product: [Fedora] Fedora Reporter: Laur Ivan <laurivan>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: laurivan, oliva, riel
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 13:57:41 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 101901    
Bug Blocks: 100643    

Description Laur Ivan 2003-07-23 06:37:38 EDT
Description of problem:
Installing Linux off a 1394 (firewire) CD-ROM fails after loading sbp2.


Version-Release number of selected component (if applicable):
Severn


How reproducible:
Dell X200 + firewire CDROM




Steps to Reproduce:
1. Load the first CD of Severn
2. Use the default install path
3. The setup hangs with "loading sbp2 module..."
    
Actual results:
Hangs and the installation cannot continue.


Expected results:
Installation would go on.


Additional info:
Might be a sbp2 reentrant issue as discussed on linux kernel mailing list..
Comment 1 Michael K. Johnson 2003-08-08 17:16:38 EDT
Isn't this the "must now rescan scsi bus after loading sbp2" issue?
In which case, anaconda would have to have that added.
Comment 2 Laur Ivan 2003-08-11 04:26:49 EDT
No. The module "crashes" (see 101901). 
Comment 3 Alexandre Oliva 2003-09-03 13:35:37 EDT
Same problem here, with a Maxtor 5000DV external hard disk enclosure.  I'm
actually using a slightly newer kernel than the one that shipped with Severn. 
FWIW, it works just fine with Shrike.
Comment 4 Alexandre Oliva 2003-09-03 19:08:39 EDT
FWIW, the kernel I'm using is kernel-2.4.22-20.1.2024.2.36.nptl (now available
from RHN, and soon from Rawhide).  The module hang I observe is described in bug
101227,
Comment 5 Laur Ivan 2003-10-03 09:42:54 EDT
Still happens on Fedora core. Redhat 9 works.
Comment 6 Michael K. Johnson 2003-10-21 15:23:39 EDT

*** This bug has been marked as a duplicate of 101901 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:57:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.