Bug 101901 - IEEE1394 dies in free_hpsb_packet
IEEE1394 dies in free_hpsb_packet
Status: CLOSED DUPLICATE of bug 103821
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: 100545 (view as bug list)
Depends On:
Blocks: 100545 CambridgeBlocker
  Show dependency treegraph
Reported: 2003-08-07 17:07 EDT by Laur Ivan
Modified: 2015-01-04 17:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:58:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
System log from 2.6.0 (46.42 KB, text/plain)
2003-08-17 10:15 EDT, raxet
no flags Details
lspci (1.45 KB, text/plain)
2003-08-17 10:19 EDT, raxet
no flags Details
Kernel Startup Log (8.77 KB, text/plain)
2003-08-17 11:05 EDT, raxet
no flags Details

  None (edit)
Description Laur Ivan 2003-08-07 17:07:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
When I attach the firewire device, the hotplug script loads the modules as it should, but after loading sbp2, it dumps a message (addresses vary depending on kernel ver/patch)

Platform dell X200 + firewire CDRW/DVD

Version-Release number of selected component (if applicable):
kernels 2.4.21 and 2.6.0 test1/2/2+mm/2+bk5

How reproducible:

Steps to Reproduce:
1. compile the ieee1394 module
2. install the new configuration
3. reboot

Actual Results:  Slab corruption: start=d552d8c0, expend=d552d937, problemat=d552d900
 Last user: [<f891d1fd>](free_hpsb_packet+0x2c/0x33 [ieee1394]) 
Data: ****************************************************************6A
Next: 71 F0 2C .FD D1 91 F8 71 F0 2C .....................
slab error in check_poison_obj(): cache `hpsb_packet': object was
modified after freeing
Call Trace:
 [<c014e5b1>] check_poison_obj+0x16c/0x1ac
 [<c014e77d>] slab_destroy+0x18c/0x194
 [<c0152532>] cache_reap+0x2d6/0x45c
 [<c01515ef>] reap_timer_fnc+0x0/0x29
 [<c01515fa>] reap_timer_fnc+0xb/0x29
 [<c012df3b>] update_wall_time+0xf/0x3a
 [<c012e26c>] run_timer_softirq+0x18b/0x429
 [<c01127e7>] timer_interrupt+0x17f/0x3be
 [<c0129051>] do_softirq+0xa1/0xa3
 [<c010cc2f>] do_IRQ+0x256/0x3a4
 [<c0124dc7>] profile_hook+0x2f/0x4d
 [<c0107269>] default_idle+0x0/0x2c
 [<c0107269>] default_idle+0x0/0x2c
 [<c010ab70>] common_interrupt+0x18/0x20
 [<c0107269>] default_idle+0x0/0x2c
 [<c0107269>] default_idle+0x0/0x2c
 [<c0107290>] default_idle+0x27/0x2c
 [<c0107301>] cpu_idle+0x31/0x3a
 [<c0105000>] rest_init+0x0/0xf5
 [<c0398725>] start_kernel+0x1b8/0x210
 [<c039843f>] unknown_bootoption+0x0/0xfa

Expected Results:  sbp2 should load normally and subsequent modules/scripts should be able to use the firewire device.

Additional info:

The system is usable, but sbp2 cannot be removed and subsequently, no attempts can be made to fix it.
Comment 1 Michael K. Johnson 2003-08-08 11:03:45 EDT
Matt, have you tested Severn with sbp2 on your setup?
Comment 2 Dave Jones 2003-08-08 11:29:05 EDT
Is this repeatable with the sbp2 module from the kernel on the Red Hat CD ?
Your report doesn't specifically mention any Red Hat kernels.

If you are only seeing it with upstream kernels, please report the bug to the
upstream sbp2 maintainer.

Comment 3 Laur Ivan 2003-08-11 04:30:02 EDT
The bug is reproductible with the 2.4.21 nptl kernel delivered on the severn's ISO.
Comment 4 raxet 2003-08-17 10:15:08 EDT
Created attachment 93688 [details]
System log from 2.6.0

Notice numerous references that firewire is detected.
Comment 5 raxet 2003-08-17 10:18:04 EDT
Ditto here. I have a Buslink 48x12x48x and it works great in ol Shrike. Severn
though with 2.6.0. See attached log above. I will also attach a copy of lspci.

Comment 6 raxet 2003-08-17 10:19:59 EDT
Created attachment 93689 [details]

More info for your viewing pleasure
Comment 7 raxet 2003-08-17 11:05:12 EDT
Created attachment 93690 [details]
Kernel Startup Log

More viewing enjoyment to help with Severn and 2.6.0
Comment 8 raxet 2003-08-27 19:25:42 EDT
2.6.0 test4 kernel made no difference in outcome. I made all the updates on
9.0.93 to no avail. IEEE1394 is dead here. I might add that usb-ohci is also hosed.

Comment 9 Ben Hsu 2003-08-29 13:49:27 EDT
I posted this to the linux1394-devel mailing list and the suggestion for this
stack trace was:
1) fix the poisoned slab
2) turn of kernel debugging as a work around
Comment 10 Alexandre Oliva 2003-09-05 08:04:00 EDT
FWIW, I can't duplicate this with 2.4.22-20.1.2024.2.36.nptl
Comment 11 Michael K. Johnson 2003-10-21 15:23:42 EDT
*** Bug 100545 has been marked as a duplicate of this bug. ***
Comment 12 Alexandre Oliva 2003-10-21 16:47:30 EDT

*** This bug has been marked as a duplicate of 103821 ***
Comment 13 Red Hat Bugzilla 2006-02-21 13:58:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.