This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 100643 - (CambridgeBlocker) Make Cambridge not suck.
Make Cambridge not suck.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: distribution (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Tracking
Depends On: 69903 81855 83668 84032 84043 84094 84258 85060 87585 88741 89773 90116 90306 90382 90638 90646 90905 90940 91067 91121 91257 91265 91289 91411 91451 91484 91486 91537 91562 91618 91689 91846 91874 91906 91932 91945 92099 92220 92233 92250 92262 92382 97041 97043 97227 97331 97395 97501 97597 97598 97692 97693 97781 97783 97796 97806 97826 97837 97845 97904 98031 98033 98086 98133 98139 98226 98233 98238 98243 TB9efd6ce0 98325 98595 98600 98767 98849 99057 99216 99261 99269 99280 99293 99323 99327 99328 99359 99371 99405 99411 99417 99442 99455 99458 99462 99465 99473 99490 99503 99510 99528 99541 99545 99557 100409 100412 100445 100448 100449 100457 100470 100471 100472 100473 100505 100515 100522 100540 100542 100545 100549 100552 100560 100561 100562 100567 100585 100611 100622 100655 100658 100661 100667 100670 100682 100689 100691 100758 100777 100855 100863 100869 100872 100874 100879 100894 100895 100898 100906 100909 100917 100920 100924 100925 100932 100944 100965 100981 100984 100986 101048 101069 101078 101107 101111 101169 101209 101213 101284 101357 101404 101413 101436 101488 101492 101558 101566 101589 101612 101621 101631 101640 101647 101654 101687 101716 101718 101733 101769 101826 101901 101926 101940 101988 102015 102040 102079 102125 102154 102222 102223 102355 102383 102501 102503 102514 102530 102539 102559 102584 102641 102647 102648 102668 102672 102673 102674 102710 102776 102795 102853 102892 102977 102985 103001 103058 103074 103110 103115 103125 103149 103150 103162 103277 103292 103331 103333 103360 103361 103362 103390 103441 103480 103488 103546 103614 103623 103630 103636 103690 103733 103769 103788 103809 103820 103821 103826 103831 103838 103871 103933 103935 104029 104037 104088 104156 104158 104173 104177 104210 104212 104213 104214 104216 104232 104239 104262 104276 104277 104287 104320 104331 104399 104421 104442 104489 104556 104609 104727 104817 104872 104880 104930 104954 104958 105360 105384 105385 105581 105582 105584 105585 105586 105588 105590 105593 105620 105633 105634 105635 105636 105640 105667 105677 105684 105746 105763 105767 105772 105776 105819 105828 105848 105856 105857 105858 105865 105880 105882 105946 105949 105969 105976 105979 105980 106027 106030 106033 106045 106046 106047 106049 IT_53880_42163_53883 106051 106053 106072 106179 106181 106189 106211 106255 106261 106264 106288 106293 106344 106387 106389 106412 106413 106432 106447 106453 106460 106492 106501 106522 106539 106563 106575 106601 106603 106604 106605 106607 106608 106609 106610 106611 106613 106616 106617 106618 106619 106621 106623 106630 106673 106689 106716 106721 106741 106757 106796 106826 106844 106857 106860 106883 106936 106962 106970 106978 106983 107007 107093 107147 107233 107316 107343 107364 107367 107378 107390 107415 107443 107472 107476 107477 107580 107612 107676 107679 107779 107780 107818 107830 107852 107853 107861 107875 107942 107990 108029 108043 108090 108096 TBc2a8d025 108191 108416 108435
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-23 18:10 EDT by Bill Nottingham
Modified: 2014-03-16 22:37 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 03:02:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2003-07-23 18:10:50 EDT
Tracking bug for the Cambridge release of Red Hat Linux (beta name: Severn).
Things that block the release.
Comment 1 Chris Ricker 2003-07-24 07:03:14 EDT
This bug depends on 90940, which I can't access. Is that deliberately blocked
(security or similar), or was it overlooked in the process of making all this
more open?
Comment 2 Bill Nottingham 2003-07-24 10:19:52 EDT
It's possible to have this bug depend on some previous bugs that were opened
internally.
Comment 3 Dax Kelson 2003-08-01 17:28:40 EDT
The default when installing RHL is the "medium" firewall. The rules it creates
are non-stateful and "suck". :)

I teach 2-3 Red Hat Linux classes a month and you would not believe how much
grief the default rules create.

For this reason, nearly every lab in the official Red Hat Global Learning
Services courseware starts with, "iptables -F" to flush all the default rules.

I nominate Bug 87585 (which has a patch) as a blocker.

The patch updates lokkit to create a stateful ruleset that provides MORE
security than HIGH, yet has NO breakage of connections (RPC or otherwise)
initiated by the host.
Comment 4 Bill Nottingham 2003-08-01 17:36:14 EDT
Added; issue is that it affects docs, help, screenshots, etc.
Comment 5 Ralph Loader 2003-08-02 00:54:32 EDT
I nominate 97845 & 98781 (they're dups).  Not being able to start dial-up
network counts as "suck" to me...
Comment 6 Leonard den Ottolander 2003-08-06 11:25:46 EDT
What about bug #101104? mc and/or vi crashing due to a segfault in Gpm_open
kinda sucks as well... And there is a patch, so assuming it is correct this
could be solved quickly.
Comment 7 Bill Nottingham 2003-08-06 12:03:24 EDT
It's on the other list at the moment.
Comment 8 Dax Kelson 2003-08-07 16:35:54 EDT
The libuser RPM is a 'A user and group account administration library'.

It supplies replacements for useradd/mod/del and groupadd/mod/del. It also have
binaries have the same name (and nearly same syntax) just prefixed with an "l".

For example: luseradd, lusermod, luserdel, etc.

The biggest potential is for the libuser commands to provide an easy way to
administer an LDAP Directory that is being used as a NIS replacement. 

However, the currently shipping libuser LDAP backend is broken.

Currently RHL/RHEL has *no* utilities to manage an LDAP server other than
creating LDIF files by hand (yuck!!), let alone specialized utilities for
managing users and groups in an LDAP-as-NIS-replacement server.

I nominate Bug 99435 (contains a patch). The patch fixes up the LDAP backend of
libuser.
Comment 9 Mike A. Harris 2003-08-18 02:43:40 EDT
Bill will correct me if I'm wrong, but this bug is to track other bug reports,
not to add comments to indicating more problems.  If you have a bug to report
or problem to report, please file a bug report in bugzilla.  If it is considered
a blocker, it will get added as a dependancy here.

Blocker bugs are just trackers, not intended for content addition, at least
thats the way they've always been in the past.  Granted, now that it is open
to the public, people are likely not aware of what the tracker is intended
for.

It's always best to have individual bugs in individual bug reports however,
and increases the chances dramatically that the given issues will be examined,
assigned, prioritized, and tracked.

Hope this helps.
Comment 10 Bill Nottingham 2003-08-18 12:34:10 EDT
Mike, you're wrong. :)

Seriously, it was posted on rhl-devel-list and rhl-beta-list that people can
nominate bugs for blocker/target status here.
Comment 11 Mike A. Harris 2003-08-21 03:19:55 EDT
Ok, thanks for the correction Bill.  ;o)  Just trying to keep things in check,
and I didn't know about the email posting.

Thanks again for the clarification.
Comment 12 Miloslav Trmac 2003-10-22 13:53:33 EDT
I think bug 99490 should be here - shipping r-c-httpd that doesn't even start
does not look good.
Comment 13 Warren Togami 2003-10-26 01:18:51 EST
Please add Bug 104205 because a working patch has been posted.
Comment 14 Bill Nottingham 2004-01-29 03:02:31 EST
Cambridge shipped, closing.

Note You need to log in before you can comment on or make changes to this bug.