Bug 101304

Summary: Panel uses theme icon instead of specified one for launchers
Product: [Retired] Red Hat Linux Beta Reporter: Nils Philippsen <nphilipp>
Component: gnome-panelAssignee: Havoc Pennington <hp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: beta1CC: jirka, jlaska
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-19 02:02:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nils Philippsen 2003-07-30 14:45:44 EDT
Description of problem:

When specifying an icon via a launcher's properties, the panel prefers a
Bluecurve icon with the same name, while the icon shown in the launcher's
properties is the specified one.

Version-Release number of selected component (if applicable):

gnome-panel-2.2.2.1-3

How reproducible:

Easy.

Steps to Reproduce:
1. Try to set the icon for e.g. Evolution to /usr/share/pixmaps/evolution.png
2. Watch the icon in the properties dialog get the desired one and the icon in
the launcher get the icon with the same name of Bluecurve. 
    
Actual results:

Wrong icon in launcher

Expected results:

Specified icon in launcher

Additional info:

I could see this with Mozilla, Xchat, even Galeon (which isn't part of RHL
anymore -- why do we ship an icon for it?).
Comment 1 Havoc Pennington 2003-07-30 14:58:21 EDT
I guess we need to not look up in the theme if it's an absolute path, or
something like that...
Comment 2 George Lebl 2003-07-30 16:09:18 EDT
But we explicity kill the path when loading the icon to fix #106649.  This is
very very ugly.
Comment 3 Havoc Pennington 2003-07-30 16:18:17 EDT
desktop file spec extension? there's no back compat extension here though.

maybe the custom icon chooser should only let you pick icons in the theme, 
not arbitrary files...
Comment 4 Nils Philippsen 2003-07-30 18:25:54 EDT
To be frank, that'd be too much "we know what's good for you". The bug isn't
that I can choose an arbitrary icon file, it's that the panel doesn't use it.
Comment 5 Havoc Pennington 2003-07-30 18:37:19 EDT
If the bug isn't fixable we need to remove the unfixable functionality, 
is all I'm saying.

I don't see a good fix due to the compat problem; the file format can be
extended, but not everyone reading the format will understand the extension.
Comment 6 Nils Philippsen 2003-07-30 19:44:15 EDT
Can you elaborate on why the bug isn't fixable? I looked at #100649 (which is
the bug George meant I guess), but I'm still not all that enlightened by reading
through it...
Comment 7 Havoc Pennington 2003-07-30 20:38:00 EDT
I don't understand the relationship to #100649 either, but 
I assume there's some reason absolute paths currently get themed?

If not then it's fixable by not theming those.
Comment 8 George Lebl 2003-07-30 20:52:45 EDT
I forgot to say gnome bugzilla #106649, not redhat bugzilla.  I'm getting lost
in bugzili (is that the correct multiple for bugzillas)?

I don't think it's as bad as unfixable, at least for the panel since we can
extend the panel for the launchers since we're the only ones using those
desktops then.  Unless of course someone dnds it somewhere else of course, then
the icon will change to however the drop location interprets the Icon= field.
Comment 9 Nils Philippsen 2003-07-31 04:44:03 EDT
Looking at gnome BZ #106649, I also think that using the basename of the icon
file is the right thing for DnD (as long as this is done consistently in all
places). In the properties dialog I'm not quite sure -- it could be one of:

- Always use the full path
- Use the full path only when using an icon not from the (current) theme
(potential for confusion when changing themes)
- Let the user choose whether to use "only theme icons" (no "Browse" button,
basename of the icon file) or not (shows Browse button, full path)

What do you think?
Comment 10 George Lebl 2003-08-04 15:18:42 EDT
See what I comitted in gnome CVS, for a somewhat blurry description see

http://bugzilla.gnome.org/show_bug.cgi?id=116586
Comment 11 Nils Philippsen 2003-08-19 02:02:38 EDT
Fixed with:

gnome-desktop-2.3.6.1-1
gnome-panel-2.3.6.2-3