Bug 104046

Summary: adjusting timezone is not reflected in applet
Product: [Retired] Red Hat Linux Reporter: teuben
Component: gnome-panelAssignee: Mark McLoughlin <markmc>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: jakub, rth
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-01 08:45:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description teuben 2003-09-09 09:30:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.7 [en] (Win98; U)

Description of problem:
adjusting the time via a timezone change is not reflected in the
applet. Once an ntp server is given, the time is changed allright,
but when I travel and change timezones, only the applet is wrong.
Mostshells, and the system time is ok. But e.g. cron is wrong, and
still looks at the old time-zone. Everything is fine again after 
I would restart X, but I don't want to loose my X session.
Obviously this is only important for laptop users.

Starting a new clock in the panel also fails with the old time.

I don't know if this is relevant, but i set my system clock to UTC.

Version-Release number of selected component (if applicable):
2.2.0.1

How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-time
2.  change timezone
3. observe 'date' command is ok
4. observe the clock applet is still showing old time
    

Additional info:

it is surprisingly hard to figure out what component (rpm) the
clock applet comes from..... i tried 'top' and activacting it,
but nothing interesting showed up....
certainly the command "rpm -qa | grep -i clock" didn't return
anything
Comment 1 Havoc Pennington 2003-10-08 17:57:11 EDT
I'm guessing libc caches the timezone information. I'm not sure whether there's
a way to force it to refresh.
Comment 2 Jakub Jelinek 2003-10-08 18:08:43 EDT
Calling tzset () causes TZ env variable to be reevaluated and timezone file
reread.
Comment 3 teuben 2003-11-23 14:52:26 EST
I'd like to add that while playing with a mandrake 9.1 box i noticed
the changing the time will adjust the time in the Clock tool on
the panel. THeir version is also 2.2.0.1, but of course they look
different to the users, since mandrake and redhat do something else
below the hood. Obviously mandrake can do it right
(one little caveat, that machine runs the hardware clock in civil
time, not in GMT, like mine). I will experiment with that to make sure
that is not the difference. But thus far i'd say the redhat version
does have a problem. I confirmed that the  version in Fedora RC1 also
exhibits the same problem as RH9. I don't recall the version of that
Clock.
Comment 4 Mark McLoughlin 2004-03-03 16:54:03 EST

*** This bug has been marked as a duplicate of 98140 ***
Comment 5 Mark McLoughlin 2004-03-04 08:29:10 EST
Wrong dup, sorry :-)
Comment 6 Mark McLoughlin 2004-08-11 04:11:20 EDT
*** Bug 123614 has been marked as a duplicate of this bug. ***
Comment 7 Mark McLoughlin 2004-10-01 08:45:00 EDT
This is fixed in latest rawhide with glibc-2.3.3-60 or later